CEC messed up after restarting tv

TV: LG 55LF5809
AVR: Onkyo TX-NR636

Since April update hdmi cec doesnt work correctly anymore for me. If my tv and avr are switched on and I restart vero2 cec is working just fine. But after switching tv/avr off and on again the remote commands are messed up. For example I press “left” and kodi shows a press to the right…The commands executed seem pretty random. I tried different settings under peripherals → CEC adapter, on tv and on avr. Only a reboot (keeping tv and avr on) solves it temporarily until I switch tv off.
Here are my logs: http://paste.osmc.io/wisohivako

Using new kernel didn’t help. Any ideas?

It’s being worked on.

I believe that a user has a similar issue.


Ok, thats good to know.
There are also 2 different Remotebuttons (back and exit) that are recognized as the same key (-> menu) and this “menu” keypress and a “homepage” keypress can’t be altered with kodis keymap editor addon.
But I don’t know if this is a kodi issue or libCEC related.

I haven’t remapped CEC keys with Kodi before, but I believe Kodi just uses remote.xml for CEC so you should be able to make changes there.

Yes, to remap CEC remote buttons you create a custom remote.xml.

You can only remap buttons that the TV will send - if the TV doesn’t send a particular button there is nothing you can do about that.

I will try to write the remote.xml file manually.

Ok,…=/ I enabled debug in kodi and typed tail -f /home/osmc/.kodi/temp/kodi.log |grep OnKey: so it shows me what is received after pressing buttons. After pressing “exit” button it shows exactly the same as pressing “back” button.
Ok so seems I have to get along with one button less, right?

If the TV is sending the exact same button code (by number) then unfortunately there is nothing you can do about that. Kodi can only work with what it is sent.