CEC not working after update

I have been using osmc on a rpi3 for a few years and I have always controlled it successfully with the remote of my avr.
After putting it of for a long time I finally upgraded to the new osmc version.
Sadly now CEC doesn’t work anymore.

I tried the powerdown everything trick but that didn’t help.

If I kill kodi and run cec-client it connects without problems and I can see keypresses and such from the remote and state changes from the avr.

So cec itself seems to be working but kodi is just ignoring it.

Does anyone have an idea how to fix this?

Is there a way to send commands to kodi? if so I could map the cec-client output myself.

I have checked kodi.log and all it says is this:

osmc@pi2:~$ grep -i cec .kodi/temp/kodi.log

2021-12-13 22:28:23.987 T:551 INFO : Register

  • new cec device registered on cec-Linux: CEC Adapter (0000

I have tried setting the port number to 1100 (that is what cec-client was using) but that doesn’t seem to help.

After I reset the cec settings to default a channel option appeared. Setting the channel to 2 did the trick.

1 Like

Thanks for letting us know.

The CEC implementation changed in Kodi v19 and it seems previous settings could have carried on from the former CEC implementation in Kodi v18 that could cause it not to work.

This will surely affect other users, so it’s good to know.