CEC not working samsung tv

Is it just me or others having problem with remotes samsung tv appears not always able to detect cec. When it work under samsung find device listed as kodi. When not working kodi not shown and only recorder is shown. Only way to get work has been reboots or going cec and hitting default.

No problems with cec on my Samsung tv…whenever I switch source to Rpi 3 osmc, the tv remote works immediately

Thank you I will keep tinkering around with it.

No problem with 3 different generations of Samsung TV here.
The only moment, “kodi” disappears from CEC menu is, when kodi is very, very busy.

This nearly never happens with RPi2 since I replaced a problematic RPi2 (rainbow square while 2.5 A PSU was at 5.0X Volts). “Nearly” means, I saw it around Feb/March. But then I switched to more frequent update channel, and the problem was never seen since then.

This still appears with my RPi1 (mostly B+), say, once per 3 month and per device. But this RPi1’s all still having RaspBMC instead of OSMC.

When it happend, one reboot (ssh login, sudo reboot) fixed this in all cases.


After last reply turn on tv and cec not working, it like cec just goes to sleep. If I use web remote works, so then I need to go to CEC hit default, save, and reboot. Then cec will work is there a setting or command to keep raspberry pi cec on constantly. I have similar problem with another tv that uses gpio.

Did as suggested, no change. When both powered up got the cec not connected warning.

Try a different HDMI cable.

Done, have tested with 4 known good cables, thinking to reinstall osmc to see if would work correctly.

Would this help
osmc@osmclvrm:~$ arm_freq=1000
osmc@osmclvrm:~$ audio_pwm_mode=1
osmc@osmclvrm:~$ audio_sdm_mod_order=2
osmc@osmclvrm:~$ config_hdmi_boost=5
osmc@osmclvrm:~$ core_freq=500
osmc@osmclvrm:~$ disable_commandline_tags=2
osmc@osmclvrm:~$ disable_l2cache=1
osmc@osmclvrm:~$ disable_splash=1
osmc@osmclvrm:~$ enable_uart=1
osmc@osmclvrm:~$ force_eeprom_read=1
osmc@osmclvrm:~$ force_pwm_open=1
osmc@osmclvrm:~$ framebuffer_ignore_alpha=1
osmc@osmclvrm:~$ framebuffer_swap=1
osmc@osmclvrm:~$ hdmi_force_cec_address=65535
osmc@osmclvrm:~$ hdmi_ignore_cec_init=1
osmc@osmclvrm:~$ init_uart_clock=0x2dc6c0
osmc@osmclvrm:~$ lcd_framerate=60
osmc@osmclvrm:~$ over_voltage=2
osmc@osmclvrm:~$ over_voltage_avs=0x1b774
osmc@osmclvrm:~$ over_voltage_sdram_p=2
osmc@osmclvrm:~$ pause_burst_frames=1
osmc@osmclvrm:~$ program_serial_random=1
osmc@osmclvrm:~$ sdram_freq=500
osmc@osmclvrm:~$ sdtv_aspect=1
osmc@osmclvrm:~$ temp_limit=85

Unlikely… Do you have any other cec devices connected to the TV such as a Chromecast?

Yes I do, easycast.

additionly have a tfc channel box

Unplug the other cec devices to rule out interference from these.

unplugged all but raspberry kodi, no change in fact after reboots can not even get remote to work.

tv is a new model un55ju6700fxza would that make a difference

Try a reinstall (maybe on a second SD Card) this starts sounding like a wider issue on your install

Currently reinstalling newest download on to another sd.

Ran install came to select country remote not work, connecting keyboard

installed and rebooted afterwards remote not working. Went to samsung source and selected raspberry pi and down arrow and selected anynet + hdmi cec, refresh option, recorder only thing listed. Still unable to make cec work.