CEC not working via Onkyo receiver

I’ve got some serious issues in my current setup getting the RPI2 with OSMC to work properly via CEC. I own a Panasonic 55ST50 and a Onkyo TXSR507/B receiver.

  • When directly connected to the TV, everything works great, Panasonic Vierra Link automatically picks up OSMC. TV remote can be used to control Kodi.
  • The Onkyo doesn’t support CEC itself, but does support CEC Passthrough.
  • When connected via the desired setup Rpi->Onkyo->TV, CEC doesnt work.
  • When I let the Raspberry boot from TV, remove the HDMI, and put it in the receiver -> Works
  • When the tv is switched on/off or RPI reboots, connection is lost and not restored.

Log from RPI->TV connection when everything works: http://xbmclogs.com/pzdfeh7wy
Log from RPI -> Onkyo ->TV (desired setup) CEC not working: http://xbmclogs.com/px9esqnge

Any help is greatly apprciated

It sounds like the Onkyo is messing with the EDID reported by TV and so breaking CEC.
As a workaround can you try following these instructions:
http://kodi.wiki/view/Raspberry_Pi_FAQ#TV_is_not_detected_unless_powered_on_first

with the Pi directly connected to TV. You should then be able to connect receiver and still have the working CEC.

Thanks for thinking along.
Tried it; didn’t help

Doubt actually whether this statement is true. Settings mention HMDI ctrl: On.

Some receivers cannot be completely controlled via cec, but the volume can be adjusted only. They don’t show up as a cec device to the tv sometimes like on my pioneer vsx920.

What popcornmix mentioned should work…

You need to ensure that the Pi is DIRECTLY connected to the TV to capture the EDID.

Once the EDID has been captured you can connect up again as it was and follow the instructions for the setup.

I don’t have that exact Onkyo receiver but I think most of them support cec but unlike most devices that only send unused buttons you use a code to send all buttons like any universal remote device.

On the Onkyo controller Just hold the correct inputs button and display for three seconds (lights will blink) then just hit 32910 (if I remember correctly I’m not home to check)

I spent a couple years not using Cec until I found out about that.

You need to ensure that the Pi is DIRECTLY connected to the TV to capture the EDID.

Once the EDID has been captured you can connect up again as it was and follow the instructions for the setup.

Have done it exactly like that, but did not have effect.

Also tried that, but without result. I did observe that after filling in this code, the receiver doesn’t register remote control entries anymore (no flashing light on the receiver). Isnt this a trick to turn your remote into ‘another remote’ old school style?

I have NR3030 and also struggled with making CEC work. For my receiver, the 32910 control code did the trick (same as what shadow mentioned above). In NR3030 manual, they mention that you can also try 33101/33501/31612 codes - all to control a CEC-compatible BDP/DVD. Although, maybe your receiver is using different control codes.

I took a look at SR507 user guide (from their website, starting on page 84), and they mention some other ‘Remote Control Codes list’ for your receiver, maybe you need to locate that list / manual. If you don’t have that list, maybe check out NR3030 instructions, as they have quite a bit of codes listed there.

Although, saying that, I have just basic stuff working, and if I get stuck (not that often), I use Yatse on my phone.

Don’t ask me how, but the TV remote suddenly started working. Think that the tips of shadow and jacek worked after all. Wish I didnt ordered that FLIRC so fast :smile:

It looks more that what popcornmix suggested is finally working (TV remote). Maybe that is precluding RPi from responding to Onkyo’s remote right now (if that control code also works for your receiver).

Maybe take some BDP, connect to a different HDMI input (one control code per HDMI input), and try to make it work with Onkyo’s remote. Once that would work, you will know that the procedure should be also working for RPi (with Onkyo’s generic control code).