CEC Not Working

New vero4k user. I’ve got a brand new TCL TV and a brand new Only AVR. Both support CEC and I’ve not found other owners with issues.

CEC module is enabled under system/peripherals.

No keypress info shown in my debug log.

Here it is: http://paste.osmc.tv/telecipija

I have swapped out the supplied HDMI cable and then rebooted everything. No change.

To simplify your debugging, I’d suggest that you start with the Vero 4K directly connected to the TV. Once you get that working you can go from there.

You said you enabled CEC on the Vero. Did you enable it on the TV?

Try power everything down at the mains for 5-10 minutes.


Vero4k is connected directly to TV now. I have powered everything down and rebooted several times. Turned CEC on TV on and off. It “detects” the Vero 4k in it’s enabled CEC list, but I still don’t see any evidence of keypresses in the debug log.

Next steps?

Is the device directly connected to the TV or is there an AVR?

Have you tried another HDMI?

What’s the model number of the TV?

Directly to the TV. I have tried the stock Vero hdmi cable as well as a high quality Amazon one.

It’s a TCL 65R615.

Well TCL Devices had been reported in the past not to work

Found a solution that seems to be working perfectly. Leaving it here for future googlers. TCL has a CEC-Remote Codes option in the service menu that needs to be enabled so that it passes remote codes via CEC.

Try this: Home x5, rewind, down, fast forward, down, rewind

Turn on CEC Remote Control and see if it works for you.

Definitely not a supported feature.


THANK YOU SO MUCH!! I’ve been trying for a week to get my new 8 series tv to control my ps4 and shield.thought I was going to have to call tcl till I ran into this post…THANKS THANKS THANKS MAN.made this accout to just say that.

Ahh…CEC, conceived to make things simpler for the average consumer. In reality, the most poorly thought out, inconsistent, and frustrating feature imaginable.

My experience is that if you dare to have different brands of equipment, CEC will require hours of frustrating piddling about and an advanced degree in stupid design. Plus when you finally get it all working nice, a simple power cut will bring it all crashing down in the blink of an eye.

It’s an absolute travesty IMHO.

(This rant is about CEC in general, not a comment on OSMC’s implementation)

1 Like

This is one of the main reasons why we ship a remote with the Vero. I’m often told it’s unnecessary and CEC is good enough, but this is really not the case.