CEC problem on PI Zero

I have a Sony KDL-40W5500 TV
For many years I have had a Raspberry Pi 1 (256M)
The remote always works OK even with the latest OSMC load.
However I have a Raspberry Pi Zero, also with OSMC.
The remote does not seem to work on the Pi Zero.
I am using the same HDMI port so things should be the same.

I should note on holiday the flat had a Panasonic TV I think, Pi Zero CEC didn’t work on that either.

Do I have to do something to enable it on Pi Zero ??
Thanks
Jim

Should work out of the box in just the same way.
Check cable if not same - and also power off the TV at the wall for a while to try to force it to forget what it knew of the previously attached RPi2.

It’s my impression that the OSMC installation comes with CEC enabled (I usually turn it off to avoid some log messages), and set for a default port.
Hve you checked the TV to see if it needs to be told to recognise and use CEC when you have the Pi zero connected?
Derek

I will try turning TV off for a while.
However
Pi 1 / OSMC CEC works out the box
Pi Zero OSMC on same HDMI port as above, no CEC (but I think the rest works OK )
Jim

Are you also using the same cable as to the Pi1?

Not really but check on Settings -> System -> Input Devices if CEC is recognized and enabled

OK thanks, how does CEC work.
Are there config files for known TVs, perhaps the Pi Zero is missing one ?

Any configuration files should be part of the standard OSMC (and invisible to the ordinary user). There are a couple of users who seem to need something special to get certain keys working - but you don’t seem to be in the same set, as your stuff works with non-zero Pi.
You may need to turn on debugging, try using the remote, and upload logs, to determine where the problem is.
Derek

OK any link to debugging CEC

Just enable debug logging, please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

But have you checked under Input Devices as I recommended and pressed enter on the CEC device?

OK I shall have a play in the morning before the wife gets up and wants the TV !

Sorted.
Set Pi Zero up with powered hub keyboard and mouse + Wifi Dongle such that I could debug if required.
Suddenly it all worked CEC/remote worked, hmmm.
Originally I had Pi Zero, USB PSU and Wifi plugged direct, no power hub and a short HDMI cable.

So started out eliminating things.

It turned out to be the short HDMI cable I got of eBay.
It looked perfect mini HDMI to HDMI so no clutter or excess cabling.
But if I use my usual HDMI metre long things work OK.
With the short HDMI all the OSMC functionality worked apart from CEC, does CEC use separate wires ?
So back to Pi Zero, USB PSU WiFi dongle plus “long HDMI” and it still works.

So do you think it because the cable is too short or missing wires ?
Thanks
Jim

The eBay listing said
0.5M Gold HDMI-Mini Type C To HDMI A Cable v1.3 Lead HDTV 1080p Tablet PC Cam

So is v1.3 OK ?
Jim

Try a search for this - last time I did, I found people on both sides, but the tech spec suggests that the wire for CEC should be there.
That said, it is not unusual to find cables without it - and there are postings on how to disconnect it to get round equipment problems.
Derek

Sorry search for what ?

Global, not forum search for HDMI CEC problems…?
Derek

OK thanks.

It is pin 13 and the requirement for that pin to be wired up has been in there since HDMI 1.0 … however, quite possible that some omit it and are never found out.

I would try testing with a multi-meter but the connectors are very small.
It only cost about £2 so will write it off.
With eBay many you win but occasionally you lose !
Thanks
Jim

Pi Zero CEC still working with my old long HDMI cable.
I guess the moral is that not all HDMI cables are equal and it’s difficult to know which will work.
Thanks to all for the assistance.
Jim