[CEC] Remote doesn't work in Kodi GUI after TV/AVR source change

Hi everyone!

When I change TV/AVR and USB source then my remote doesn’t work in KODI GUI. This problem is related only with remote because when I run movie and I change to TV and back, movie still playing but I can not do anything by my remote controller. This same problem occur when I turn off and turn on my TV.

Everything was working fine some days ago and it has happened after last update. At the moment only one way to solve this problem is restart raspberry pi but this workaround is very bothersome.

My TV and Remote:

NOTICE: Starting Kodi (16.1). Platform: Linux ARM (Thumb) 32-bit
NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)
NOTICE: Kodi compiled Oct 29 2016 by GCC 4.9.2 for Linux ARM (Thumb) 32-bit version 3.16.36 (200740)

Logs: http://paste.osmc.io/yifisojave

Are you using the remote directly with the Raspberry Pi or through the TV with CEC? Usually you woudn’t see a TV remote set up in lirc.

You have some corruption in your system log which would suggest your SD card is failing or has become corrupt.

I would take the SD card into another linux machine and run fsck -fvp -C0 on it to verify that the filesystem is ok.

I have verified the file systems on other linux machine and all looks OK

VirtualBox:~$ sudo fsck -fvp -C0 /dev/sdc7
fsck from util-linux 2.27.1

  163760 inodes used (18.32%, out of 894080)
     128 non-contiguous files (0.1%)
     148 non-contiguous directories (0.1%)
         # of inodes with ind/dind/tind blocks: 0/0/0
         Extent depth histogram: 155767/71/2
 1855820 blocks used (51.92%, out of 3574144)
       0 bad blocks
       1 large file
  133882 regular files
   21793 directories
      12 character device files
      25 block device files
       2 fifos
      23 links
    8027 symbolic links (7863 fast symbolic links)
      10 sockets

  163774 files

I’m using TV with CEC and all worked fine some weeks ago!
I found one workaround to avoid reboot raspberry pi.
In Samsung TV is option to search devices with Anynet + (HDMI-CEC) and then I can get back remote in osmc but this is not solution. It looks like after switch I’m loosing connection by Anynet+ and when I go back to osmc there is no search to do reconnect.

My OSMC CEC configuration:


NOOBS Auto-generated Settings:


There’s nothing obvious about CEC in your logs, but they’re not debug logs so are limited.

Can you enable debug logging, reboot, recreate the problem and then upload a new set of logs so we can see more details?

Please to find my logs in debug mode:


My steps:
1 Enable debug logging
2 Reboot
3 On startup the TV switch to Kodi(I can use my remote)
4. Switch source to TV
5. Switch source back to KODI (no remote connection)

Thank you for posting your logs. I have to admit I’m none-the-wiser from reading them - I can see nothing obvious. However there are many here wiser than me and I’m sure they’ll be along to offer advice shortly.

Just a heads up to the original poster. I have the same problem with a Samsung TV since a recent update. Good to know it’s not just me.

This is my post https://discourse.osmc.tv/t/cec-remote-stops-working/

I still wonder whether it’s a power issue though my tests seem to tell me it’s not. Have you tried with a different power supply unit?

I was trying different combinations and in my opinion this problem isn’t with a connection. It seems that in last Samsung update, they have changed something with CEC and now when you go back to USB connection is CEC is not reconnected.

At the moment I’m using manual search Anynet + (HDMI-CEC) connection but will be very happy when someone solve this problem :slight_smile: