CEC remote no longer working

My Samsung TV’s remote is no longer able to control the Vero 4K.

It has done previously, with no particular config by myself. I am unsure if and what updates have been applied. I have noted recently that even when it was working, it would take 20secs before the Vero would execute the commands.

Logs have been uploaded:


From some googling it looks like samsung tvs use Anynet+, for cec. I would check the settings on TV.

The normal recommendation is to turn the tv and the vero4k off and remove power for 10 minutes, then re-power.

Thanks Tom.

I had intermittent problems with CEC using the default HDMI cable.
Changed those and it solved everything.

@Tom_Doyle tried power cycling, no change in behaviour.

In the TV’s Anynet+ settings, I can search for devices, where it finds the Kodi device as well as my AVR SR578 says it has “Connection settings complete”. When I then choose the Kodi device, the Anynet+ overlay is on screen and finishes with “device is not connected” message.

@Numiah I tried a different hdmi cable, same result.


Is the vero4k connected directly to the TV?

Thanks Tom.

Onkyo’s ARC channel connects to it’ “Out” port

Try Vero->Onkyo->Samsung. That works for me (albeit with a Yamaha AVR and Panasonic TV)

My AVR isn’t 4K capable. This is why the TV is directly connected to the Vero. AVR is only being used for its audio / speaker setup (in time to be retired for a Soundbar - another story)

If you disconnect (this is just for testing) the onkyo and any another hdmi equipment (if there is any), Are you able to choose the kodi and not get the error message?

Thanks Tom.

I have tried, and have currently left it, without the AVR physically connected. Still cannot control the Vero.


Try turning off Anynet+ and removing power for 10 minutes again. Then re-enable Anynet+ and try enabling the device again.

Just out of interest does onkyo support cec, if so what happens when you try to enable cec on that?

Thanks Tom.

It’s because he has two devices taking the Player role on the bus.

Try: HDMI-CEC some buttons not working on Vero2 that do work on Pi2 - #8 by sam_nazarko

Ahhh, that seems to have done it! Maybe that is the proper process to reset cec fully, at least on this Samsung model.

Not thoroughly tested everything, just enjoying a moment of success…

The AVR does support CEC, i thought they simply call it ARC (auto return channel) on receivers? But I am able to control volume and it turns on/off with the tv. All I use it for… waste, huh?

1 Like

If / when it happens again, try the above steps.
Welcome to the fun and games of CEC…