CEC Remote stops working

A little while ago I added owncloud (lightweight with nginx, php-fpm and sqlite) to my raspi 2. Approximately at the same time my remote stopped working. There were also some upgrades at the same time. I’m still not sure what is the actual cause. I have tested disabling the nginx and php-fpm but it still happened.

When I say it’s not working I mean when I switch to a different source and then back to the raspi the pi does no longer react to the remote. I can go to the sub menu of the source on the TV and activate it again through the Anynet menu item. But I have to do this every time after I change to a different source.

It could be a power issue. I still have to test this. I have always had quite a lot of power flash warnings. I am running a setup with two 2.5 usb hard disks which are pretty power hungry as they are running raid1. But I also have a 3.5A Icy box USB hub to power it all. Attaching a separate (phone charger) PSU just for the raspi didn’t make any difference.

I’ll test removing the USB disks to see whether it still happens. It’s all been running fine for over a year. Does anyone have any other ideas how to debug this? I tried with enabling the dedicated cec debug log and I could see the output was slightly different when it works but nothing helpful there.

I have disconnected the USB discs to rule out power issues. The problem persists though.

Here is what is logged in the CEC category when I switch from the TV to the raspi (osmc): http://paste.osmc.io/likimuloxu.coffee

It looks like it’s wrong. It’s deactivating the “Recorder” when that should be activated. Could it be a problem with the upgraded CEC library? I noticed it was upgraded at about the same time as the problems started.

Any ideas how I can debug this further? I’m thinking of downgrading what I can, starting with the kernel…

Update: even when just the screensaver kicks in, the remote stops working. http://paste.osmc.io/ayaxenifoc.css

Additionally, this is what gets logged when I activate CEC/Anynet on the TV http://paste.osmc.io/tivikedozi.coffee