CEC stopped working

Hi there all,

so, my Raspberry Pi 3 is connected to a Denon AVR which itself is connected to my Panasonic TV.
With this combination I was able to use the Panasonics TV remote to control my Pi3 via CEC.

Now, I was on vacation for a week and decided to take the Pi with me so I could watch some movies every now and then. So I connected the Pi with the Philips TV set in the holiday home and everything went fine, except for the fact that I couldn’t use the Philips TV remote to control my Pi. So I used an external USB keyboard instead.

When I got home and reconnected my Pi3 with my Panasonic TV, a message appeared at startup saying, that the CEC Adapter could not be initialized – and it continues to do so ever since. I’m pretty baffled about this because (as far as I can see) absolutely nothing changed in terms of the hardware I’m using at home. Same cables, same TV, same AVR.

Now the thing that puzzles me the most: Even a whole new fresh install of osmc would bring up the same error at startup! I used a differend SD card and did a fresh install of osmc but the same error “CEC adapter could not be initialized” comes up every time osmc boots up. I’m pretty speechless about this, it definitely worked for years before without any issues.

Here’s the log file: https://paste.osmc.tv/qijikubula
(One more thing: osmc is installed via noobs)

Things I’ve tried so far:
– diconnecting AVR, TV and Pi from power and HDMI for several minutes
– replaced the libcec as suggested in this thread.

Any help would be greatly appreciated!

Thanks in advance!

Try turn everything off at the mains for 10-15 minutes
Try another HDMI cable

Thanks for your prompt answer, sam!

I already tried unplugging everything and left it for about 30 minutes or so.

I didn’t try using a different HDMI cable, but then again it worked fine with the exact same cable before.
Nonetheless I’m gonna give it a try…

So, again I disconnected everything and waited for 20 minutes before reconnecting power- and hdmi-cables.
This time I used another hdmi-cable (with networking). Sadly with the same result.

I then switched the Pi off, connected it to another hdmi port on my AVR and after that to the Panasonic TV directly. Unfortunately neither of those thing made any difference.

Lastly I ssh-ed into to Pi and did an ‘apt-get dist-upgrade’, again without any effect on the issue…

Was anything else connected to the TV at that time?

Maybe try (on another SD card) a older OSMC version or other OS to ensure it not a hardware problem (maybe you damaged the CEC pin when moving around)

Ehm, actually yes, the AVR. I’ll try again without it.

As mentioned above, I was puzzled to find, that a fresh osmc install on another SD card brought up the same error. So, yes, good point, a damaged CEC pin would be a possible scenario, I guess…


After I reconnected the Pi with the TV directly and disconnected the AVR from the TV set, CEC was actually working! So probably no CEC pin damage then.

Connecting the Pi back to the AVR and the AVR to the TV set however resulted in the same error again.

Ok, so I’m trying to wrap my head around this. So that indicades a problem with the AVR / TV HDMI-connection then, right?

Thanks for your suggentions, fzinken! Definately a step forward!

I searched the logfile (using component debugging for CEC) and stumbled across this:

13:21:44.916 T:1805022192 DEBUG: CecLogMessage - logical address ‘Playback 3’ already taken
13:21:44.916 T:1805022192 DEBUG: CecLogMessage - Playback 3 (B): device status changed into ‘present’
13:21:44.916 T:1805022192 ERROR: CecLogMessage - AllocateLogicalAddresses - failed to allocate device ‘0’, type ‘playback device’
13:21:44.916 T:1805022192 ERROR: CecLogMessage - failed to find a free logical address for the client
13:21:44.916 T:1805022192 ERROR: CecLogMessage - failed to register the new CEC client - cannot allocate the requested device types
13:21:44.916 T:1805022192 ERROR: CecLogMessage - failed to register a CEC client

So the Pi “fails to find a free logical address for the (CEC) client”…