CEC stops working after Kodi19 upgrade

Greetings, all.

I just upgraded a long-working OSMC Raspberry Pi to the new Kodi 19 release, and upon first reboot, CEC stopped working. (I first noticed this when, following feboot after the upgrade install, my Vizio remote wouldn’t let me clear the dialog message regarding addon migrations). My box is running through a Pioneer VSX-LX102 receiver a Vizio M558-G1 TV, and CEC integration has been working with no problem since I settled an initial configuration issue over a year ago.

Per the Kodi 19 upgrade FAQ and bullet regarding CEC failures, I have powered down each device in the chain - the TV, the Pioneer, and the Raspberry Pi, none of which corrected the problem. I have manually disabled and then re-enabled CEC on the Pioneer, and the Vizio and the Pioneer continue to communicate correctly over CEC. Only the OSMC box remains grumpy.

I verified that the configuration files that I had to modify to get CEC to work previously still retained their working values (considering the possibility that the upgrade overwrote those files), but they were correct/unchanged.

I have verified that the Vizio still “sees” the Kodi in its CEC device list, and that HDMI-CEC is enabled through the Pioneer (all this was working previously and I had no reason to suspect any of it had changed, but I verified it nonetheless for completeness). Turning on the Vizio turns on the Pioneer, all of which occurs through CEC, so the last link in the chain remains the Kodi 19 upgraded Pi box.

Right now, I can only control OSMC via Kore, and I’m going to hold off upgrading my other box until I get a better sense of what might be going on in this situation.

My logs can be reviewed here:

Thanks for your consideration and assistance. I’m hoping with the logs and description here I’ve provided sufficient information for further review.

I have uploaded new log files with CEC specific module logging and debug logging turned on.


In your old thread you found that your setup did not play well with the default of OSMC showing up as recording device 1 (1) but started to work when you forced it to be player 1 (4). I think your logs are showing that it is back to being device type 1 again…

2021-08-09 17:17:11.798 T:472     DEBUG <general>: CecLogMessage - detecting logical address for type 'recording device'
2021-08-09 17:17:11.798 T:472     DEBUG <general>: CecLogMessage - trying logical address 'Recorder 1'
2021-08-09 17:17:11.798 T:472     DEBUG <general>: CecLogMessage - << Recorder 1 (1) -> Recorder 1 (1): POLL

I think the file name for the CEC settings may have changed here as when I look on my updated RPi I see them being saved as cec_CEC_Adapter.xml now where they used to be rpi_2708_1001.xml so take a look to see if you have a new file that needs to be tweaked like you did with your old one.

If there is not a new file then I would suggest to ssh and

systemctl stop mediacenter

then delete any cec related xml files in .kodi\userdata\peripheral_data then

systemctl start mediacenter
systemctl stop mediacenter

which should have generated a fresh file that you would then edit to change the “device_type” value from 1 to 4.

1 Like

BINGO!!! That did it. I was that close in thinking the file had been overwritten, just didn’t think about it being renamed. Thanks!

1 Like