CEC stops working after suspend

Whenever Kodi goes in suspend mode (e.g. turn off the TV), CEC stops working. The only way to get it working again is to restart Kodi (not the Vero 4K+) and turn off (not a typo) CEC in the input menu. This is new, as I used to be able to wake up Kodi simply by selecting it as source on the TV and pressing any button on the remote. Any way to get CEC working again?

Try powering everything down at the mains for a few minutes

I tried this already with no success

Haven’t changed anything CEC related in the last update.

Which version did you update from?

Have you checked to see if your TV or AVR got a firmware update recently?

I am using 2024.04-1. I always update so it would have been from the previous release. My Samsung TV, which the Vero is directly connected to via eArc, is still using the same firmware.

Thanks for clarifying. Haven’t changed anything CEC specific on Vero V recently.

I changed some CEC settings a while back though but they would only be changed for new installs and not older ones. Have you reinstalled the software on your Vero V at all?


No, I haven’t reinstalled OSMC for years

I guess UbuRoi is using a 4K + as stated in the original post.
According to your v20.5 update post, there were CEC-related changes:

I missed that.

I added some retries when a CEC command times out on Vero 4K / 4K +

There was also this change a little while back:

commit 25cf36935863ca793a33492876cc34f0dd389791
Author: Sam Nazarko <email@samnazarko.co.uk>
Date:   Thu Jan 4 16:44:15 2024 +0000

    [package] [mediacenter-osmc] Improve CEC behaviour further: do not suspend device on TV power off; use OSMC as OSD name
    Signed-off-by: Sam Nazarko <email@samnazarko.co.uk>

It would only affect new installations; so perhaps you should not suspend the device when the TV is turned off.

Thank you for your help. For anyone with a similar problem on a Samsung TV, it looks like I had activated Input Signal Plus by mistake. Deactivating it solved my CEC issues.

I don’t know what that is, but I appreciate you coming back to us about this. I suspect you won’t be the first person to have such an issue with this feature.