CEC trouble with Vizio/Pioneer AVR

Hello, all.

I have a Raspberry 2 OSMC box that has worked flawessly since I built it a couple of years ago. Updates have been maintained.

I opted to try enabling remote control via CEC (have been using the Android KORE app), but I have had no success.

My setup is a brand new Vizio M558-G1 televsion with a Pioneer Elite VSX-LX102 AVR. I have enabled CEC on the Pioneer and the Visio, and when I perform a “Device Discovery” within the CEC menu of the TV, the “Kodi” device apepars in the list. So, to the extent I can discover, it appears that HDMI-CEC communication between the TV, through the AVR, and the OSMC box is working; however, no remote keypresses from the VISIO remote work at all. The Vizio TV has a built-in flavor of Chromecast (called Smartcast), as does the Pioneer AVR (audio only).

I have uploaded system logs per the support guidance and have the following pastebin link for review, but I Fear they wil show no activity across CEC:


I have ensured that CEC is enabled in the Input->Peripherals section, and rebooted both soft (console command to reboot) plus a hard power-down and restart. Each time, I verified that the proper CEC device was shown in Input->Peripherals.

What have I attempted so far (none of which have had any effect):

  • Within the /usr/share/kodi/system/peripherals.xml file, I have changed the device_type from 1 to 4
  • Enabled setting the device active on startup

I have tried to monitor activity on the CEC via cec_client, but see no activity in the monitor while pressing buttons on the Vizio remote.

Should I change or remove any notion of configured remotes?

At this point, despite the appearance of KODI in the TV’s CEC scan menu, I see no evidence that CEC commands are being sent to the device. I would appreciate any suggestions toward resolving the issue. I have a nearly identical OSMC setup against an older Insignia TV in our bedroom and CEC works almost flawlessly from there.

Thanks in advance.

I’m currently having very similar problems between OSMC on a Pi 3B+, my Pioneer Kuro Plasma TV and Pioneer VSX-930 which started last week out of nowhere.

My initial issue when setting this up a few years back was that my AV remote needed to be outputting the TV’s remote codes, so I eventually realised this using cec-client and programmed my amp remote to use the same codes as the TV remote on the input on the Pi is connected to.

Have you tried using the OSMC remote app Yatse to do a “CEC-Activate” from the power button menu? Currently that is the only thing other than rebooting the Pi which allows CEC to function.

You should not be editing that file. I’m pretty sure that file is not what you think it is. I assume you were trying to switch from a recorder to a player? Wrong file, not your issue anyway.

FYI running that program kills CEC in Kodi until you restart.

CEC works alongside other input devices without any conflict that i’ve found.

I think I would start by plugging the RPi into the Insignia and see if it works there. If it does you can then try swapping around cables and bypassing the amp to figure out exactly where your issue is.

“FYI running that program kills CEC in Kodi until you restart.”

Yes, I found that out, and have restarted/rebooted many times since then. I was pointing out that it was among the steps I tried to research before posting here.

“CEC works alongside other input devices without any conflict that i’ve found.”

That’s what I expected as well, but I thought the issue was at least worth offering in case there might be tangential relevance.

"You should not be editing that file. I’m pretty sure that file is not what you think it is. "

What I did was posted as a solution to a similar problem. It did not work for me; the OSMC box behaves as it always did.

Have you tried using the OSMC remote app Yatse to do a “CEC-Activate” from the power button menu?

Yup - that activates the OSMC box, but nothing else. CEC still doesn’t work from the TV remote.

I have continued to research this issue, and have a bit more information to provide. It still isn’t working.

  1. I have changed cables from the PI box to the AVR; no difference. CEC still does not work.
  2. I connected the PI directly to one of the HDMI inputs on the Vizio TV, eliminating the Pioneer AVR; no difference. That would suggest to me that the Vizio, for whatever reason, is not sending CEC signals down HDMI despite the fact it can detect/query CEC devices and it does detect my AV Reciever and the KODI box.

This now does tend to shift my research toward the problem being with the Vizio, although there obviously stil exists the possibility of some configuration problem on the Pi box.


Have you tried something like the following which I found google searching your “[vizio model] cec issues”?

Turn tv on, Uplug with tv on, Hold power on tv itself 10 seconds, Plug in and turn on

Have you confirmed that the firmware on the TV is updated to the latest available?

No, I have not done the hard reset - primarily due to so much prior experience with that reset really not doing anything. Firmware is latest.

I would remove ALL other input devices from the TV, completely shut down pi and tv, completely boot TV and set to desired input, only then boot the pi, and test with a known working HDMI cable, preferably one that is confirmed to work with this Pi and another TV. I would also try with your second pi and this TV as well under the same conditions.

I see on the Kodi forum where there were some people reporting control working if it was switched over to being seen as a player instead of a recorder. You edited the wrong file to make that happen. I would try setting it via terminal with…

systemctl stop mediacenter
nano ~/.kodi/userdata/peripheral_data/rpi_2708_1001.xml

Fair enough. I’ll try that just as soon as the movie we’re watching is done :slight_smile: . Thanks!


I had posted that this didn’t work, but in reviewing that xml file, I realized I had not saved the file properly.

I redid the change, rebooted, AND MY VIZIO REMOTE NOW WORKS!!!