Change of refresh rate does not occur for 10 seconds on some video files


The problem I’m having is that, on certain video files, the change of display refresh rate does not occur immediately. Rather it happens after exactly 10 seconds of playback causing a black screen for a second or two then the video plays as normal. The last thing you want when you’ve just fired up your favourite 80’s cartoon intro is to have everything stop all of sudden, even if it is only for a moment. :wink:

This doesn’t occur on all video files, most play fine without the late refresh rate change. I think it may be something to do with the video encoding because, if one episode in a series does it, they will all do it. Whereas another series will be fine.

Here’s a log if it’s helpful:

EDIT: I thought I should add that I have Adjust Video to Display disabled and the Refresh Delay setting also Off.

Try setting ‘Adjust display refresh rate’ to ‘On start/stop’.

Thanks for the reply. Sorry, I should also have thought to mention that I have tried this. Whether it’s set to “Always” or “On start/stop” it still doesn’t change until 10 seconds into the video. Obviously, if I set it to “Off” then the problem doesn’t occur but then, of course, the refresh rate doesn’t change at all.

Have you tried to make a backup of your .kodi folder and try to play one of the impacted videos with a clean kodi install?

The default behaviour in the latest Leia builds should address the issue.

Does this only impact Leia? Because @Turisu1 seems to be still on Krypton

Looks like you have an update issue, maybe try to fix that first.
libshairplay-osmc:armhf (0.1.5, 0.1.7) Error: Sub-process /usr/bin/dpkg returned an error code (1)

I am on Krypton running the December update. Every time I update I get an error message stating that something to do with SSH has failed to install. The update always seems to go through regardless so I never pay it any mind.

Looking at my own posted log, the issue seems to be here:

10:13:15.283 T:4076835408  NOTICE: Display resolution ADJUST : 1920x1080 @ 60.00 - Full Screen (16) (weight: 0.004)
10:13:15.798 T:2865734400 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
10:13:25.583 T:4076835408  NOTICE: Display resolution ADJUST : 1920x1080 @ 59.94 - Full Screen (21) (weight: 0.000)

When playback starts, the player attempts to set the display resolution to 60.00 then 10 seconds later it tries to set it again to 59.94 which is double the framerate of the source video and presumably what it should be setting it to initially.