Channel logo icons not loading


I have a problem with channel logos not loading on the OSMC’s PVR & Live TV screen for the iptv channels. I have logos provided from a local folder, and loaded with "file:///home/osmc/logos/<icon.png> in tvheadend. Instead the logos, the thumbnails from current live programming listed in EPG are loaded. Everything used to work fine until the tvheadend was updated to v4.2.8.

I’ve tried to t-shoot it, and this is what I’ve done:

  • deleted everything in /home/osmc/.kodi/userdata/Thumbnails,
  • deleted “Textures13.db” in “~/.kodi/userdata/Database”,
  • deleted everything in ~/.hts/tvheadend/imagecache/meta folder.
  • rebooted the device.

The database, and thumbnails were rebuilt, but the correct logos would still not load, and the live programming thumbnails would appear instead. When I start the stream the correct logo appears in the top right corner.

I don’t know what the issue is. Is it with the skin? I use the default osmc one. Would anybody know how to resolve this problem?



Where is this set? Needs to be under user icon for each channel under Channel / EPG → Channels. Rather than under Picon on the general setup tab, I mention this as this the mistake I made when first setting this up.

Thanks Tom.

The URL is specified for each channel as user icon in Channel → EPG → Channels.


Have you got “Update channel icon:” ticked under epg grabber?

Thanks Tom.

Yes, I’ve done it. I noticed, that the icon from local folder is being replaced by ‘https’ URL obtained from the EPG. I don’t know how to turn off loading icons from online url, and use local file. I’ve tried to delete the EPG source for given channel in EPG Grabber settings, then change icon source in Channel / EPG to ‘file:///’, but after reboot it comes back to ‘https’ source. In the past it wasn’t happening this way. Probably, it would be fine to use ‘https’ links to grab icons, but for some reason the device does not recognize icon names properly. I think, the icon names are formatted incorrectly. When I downloaded them to the local folder previously, I had to rename them in order to have them working.


It appears the issue might be with the osmc skin, that is caching icons. I configured the tvheadend on the NAS same way as on the Vero 4k+, and pointed the tvheadend client to NAS. The icons would not load, just live TV thumbnails. I used tvheadend client on Kodi 19-PC and pointed it to the NAS. All icons, EPG loaded properly. Lastly, I pointed the tvheadend on kodi 19 to the tvheadend server on Vero4k+, and all logos, EPG loaded correctly as well. So, it appears the problem most likely is with the osmc skin on Vero. How can I fix it?



If settings are reverting after a reboot, this sounds like a possible file system corruption. Please provide some logs, so we can see whats going on. Details can be found here:

Thanks Tom.

I have investigated this problem more, and found that it related to the OSMC image version. I have re-imaged the device to OSMC version 2020.06-1 and the problem was fixed. All icons loaded properly along with the EPG. After imaging the device with OSMC version 2020.10-1 the main problem has returned again.

The differences between the two versions are the OS builts:

2020.10-1 (Buster) → TVH Server Build: 4.2.8 (2020-08-13T12:14:06+0000)
2020.06-1 (Stretch) → TVH Server Build: 4.2.8 (2020-08-13T12:14:06+0000)

One thing to note, I used to have a Dev version of Buster installed prior to 2020-10-1, and there were no issues.

I am trying to upload a log file, but it is too big. Can it be compressed?

osmc@osmc:~$ paste-log /boot/uploadlog.txt
Unable to upload log. Log file is too large. (11MB)

You need to reboot twice before creating a log to vacate the the previous log files.

Uploaded the log file. The sensitive info has been REDACTED.

I created a small playlist to avoid large log file.

I think, the issue is here. I hope I can post it.

INFO: easy_acquire - Created session to https://REDACTED
INFO: Previous line repeats 1 times.
DEBUG: CCurlFile::GetMimeType - https://REDACTED/media/akpa3396162.jpg → image/jpeg
DEBUG: CurlFile::Open(0xf06464c0) https://REDACTED/media/akpa3396162.jpg
DEBUG: CCurlFile::GetMimeType - https://REDACTED/media/akpa3414441.jpg → image/jpeg
DEBUG: CurlFile::Open(0xf0456458) https://REDACTED/media/akpa3414441.jpg
DEBUG: ffmpeg[EABFF0E0]: [swscaler] No accelerated colorspace conversion found from yuv420p to bgra.
DEBUG: Caching image ‘https://REDACTED/media/akpa3414441.jpg’ to ‘8/8706fa2a.jpg’:
DEBUG: Caching image ‘https://REDACTED/media/akpa3396162.jpg’ to ‘a/ab3b60e2.jpg’:
DEBUG: cached image ‘special://masterprofile/Thumbnails/a/ab3b60e2.jpg’ size 814x540
DEBUG: cached image ‘special://masterprofile/Thumbnails/8/8706fa2a.jpg’ size 1280x720