Cheap HDMI Switch Switcher that works/ can be made to work with ATV1 + OSMC?

I just a cheapo one online to Switch between 2 laptops and ATV1 on a Monitor.

The switch, does some auto detection and for some reason the laptops can drive the output, but ATV1 output is a bit finicky.

If I play a video directly to Monitor, keep it going and then connect it via Switcher it works.

But, if I boot from scratch or sometimes from idle mode, then it wont show me the ATV1 output via the Switch.

I am wondering if there’s some settings in OSMC that can be tweaked to drive this?

Or if anyone else is using some inexpensive HDMI Switcher that they can recommend/ link to? (Amazon/ Ebay?)

Thoughts/ Recommendations?

PS: Is there a more recent ATV1 OSMC release? I havent see the TINY update available pop up notification icon in a while… :slight_smile:

The latest version of OSMC is 2016.08-1 (August)

Thanks :slight_smile: Just noticed the downloads list. For sake of stable behavior on ATV1, should I go to Aug or slightly older build - July/ June?

Any thoughts on what/ why ATV1 + OSMC does differently with/ on the HDMI output as compared to a Windows laptop?

All ATV builds are stable. Always use the latest.

Your PC behaves differently because it’s a completely different device running an entirely different OS and set of drivers. You should configure an EDID via Xorg.conf

Thanks for the insights. I did google for it and it brough up lot of resuls - configure an EDID via Xorg.conf - Google Search

Could you point me to the one that fits best (as a HOW TO) with your advise? Thanks.

https://osmc.tv/wiki/apple-tv/configuring-component-output/

Thanks. But this is for component output. What should I change/ do for the HDMI output?

This may help: http://kodi.wiki/view/Creating_and_using_edid.bin_via_xorg.conf#Method_3:_Nvidia_Xorg_driver_log_parsing

1 Like