Choppy 1080p HEVC

I just discovered some problems with playing back HEVC encoded anime Ghibli Collection movies.
They are playing choppy right from the start, and when I hit OK button (to display player controls and progressbar) it does frequently like if its seeking.

I have vero4k with latest OSMC.

But, when I disable hw acceleration, it plays back OK…of course until CPU gets to 100%.
Here is mediainfo:

ID : 1
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main@L5@Main
Duration : 1 h 12 min
Bit rate : 1 234 kb/s
Width : 1 920 pixels
Height : 1 036 pixels
Display aspect ratio : 1.85:1
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Bits/(Pixel*Frame) : 0.026
Stream size : 637 MiB (92%)
Default : Yes
Forced : No

ID : 2
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Codec ID : A_AAC-2
Duration : 1 h 12 min
Bit rate : 101 kb/s
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 SPF)
Compression mode : Lossy
Delay relative to video : 20 ms
Stream size : 52.2 MiB (8%)
Language : Japanese
Default : Yes
Forced : No

I have more files like this and all of them behave the same. Any other HEVC encoded movie plays back OK. Have anyone encounter similar behaviour? Thanks.

Hard to advise here without a log or sample.
Have you tried playing the file from local storage?


Sure, here are the logs:

On 17:44, I started playing:

  1. played with hw acc on from local storage
  2. played with hw acc on from external HDD via USB, like I always do
  3. played with hw acc off from external HDD via USB, like I always do

Playing on PC by MPC-HC is all OK with HW acceleration on.

Enable ‘Adjust Refresh Rate’

Just tried it, set it to “always” also tried restart vero4k…no success
The video is encoded in L5.0…is that ok? I dont know what levels can amlogic handle.

That looks in spec – so should be supported
Can you make a small sample of the file so we can check it here?


I have made a sample:!AvxQjdxOFjNVin2Ij18l-cTVm8Xr

In the meantime, I think I found the culprit…with most probablility, its the video file itself.
I have reencoded it into HEVC again with ffmpeg (HEVC to HEVC), audio and subtitle streams just copied.
And now it plays flawlessly.

I think its have been encoded with some weird settings, which amlogic HW decoder does not like.
Never experienced any other movie(s) with such behavior, and I do have pretty big HEVC collection.

Just from curiosity, there was nothing even in the logs which can point us in some direction?

I did not get a chance to study the sample just yet


Thats okay :slight_smile:
At least, I would know what can cause it, just from curiosity.
Feel free to take your time. By now, I have it resolved by reencoding. Its anime, so quality impact is not noticeable.