Choppy 25 FPS 1080p playback on Vero 4K


I still have choppy 25fps playback after late 2021 upgrade.

Since then, in the list of available resolution 1080p 25 is missing. My TV defenetly has this resolution. So - where can I add this resolution to the list?

Allow double framerates and change resolution on start/stop didn´t help for me.

Please post logs so we can check what’s happening. 1080p25 has always been problematic for Kodi, especially for 1080i sources. Most people find playing at 1080p50 works fine.

Hi graham,

for now the problem is gone.

This is, how I got back all supported resolutions from my tv back into the list:

Settings - System - Display
Change “Display Mode” from “Full Screen” to “Windowed”
Got an empty black screen, so I had to unplug the power-connector from my Vero 4k to reboot.

After reboot all my tv-resolutions went back into the list - including 1080p25 and 4kp25 - so I could add the whitelist.

Maybe the change of the diplay-mode re-read the tv-settings from HDMI.

I hope the will work for other people with the same problem…

I wouldn’t recommend that. ‘Windowed’ doesn’t work and could get you stuck with no picture permanently, but you got a away with it!

For other users reading this, unplugging and re-plugging the HDMI cable would probably have had the same effect and is less risky.

Need to see logs to understand what’s going on here.

I understand the need of logs.
But this log might be really big - because the problem comes not immedeately after reboot.
In this case, playback was fine for four days.
Then almost all resolutions were gone again - left only 23,98 and 24fps modes.
I will start recording the log and tell you, how long it took to reproduce this issue and how big the logfile is.

Meanwhile: is there a script to reinitialize / reread HDMI port? Something like “init x” from shell?

Restarting Kodi Power->Exit causes Kodi to re-read the EDID.
Unplugging and re-plugging the HDMI cable causes the EDID to be re-read from the display and Kodi to re-read the EDID.
echo now | sudo tee /sys/class/amhdmitx/amhdmitx0/attr re-writes most of the HDMI registers.

1 Like

After all there is still some choppy 25fps playback with massive frameskipping.

Here are my logs:

Here is the mediainfo: GeneralUnique ID : 1195555952548973782387980975 -

Thank you in advance,


Does it work better if you force the output to 1080p25 using the video OSD?

@grahamh : sorry no. this was the first thing that i tried…

Hmm, maybe Kodi has some problems with certain kind of files…

I remuxed the x264 AVC files with MKVToolnix with options “no extra compression”
(instead of determine automatically) and checked “fix bitstream timing info”.

I only checked this with two files - I will check more and report here.

Another choppy file:

Also soved by remuxing with no compression & fix bitstream timing…

Is there another version of Kodi inside OSMC to test those files with?

You can try some improvements in the Debian Bullseye testing thread. This will be made a stable release soon.


Hello @sam_nazarko , I’m having much the same issue. 25fps content plays very jerky my Vero 4k+ (although it’s fine on my PI4 with osmc). I’m not sure what combination of settings to use to make the issue go away?

Logs attached (I think)


Nothing obvious there. Please turn on debug logging for Kodi and post logs again.

Hi @grahamh , thanks for replying. I think I’ve done a full debug log. I restarted, played a file (an episode of Mortimer & Whitehouse) and it played fine! I then stopped playback, and restarted playback from the beginning and it stutters. Same file, both played from the beginning, same file location. Only one instance of playback stuttered.


Many thanks

I can’t see anything supicious in those logs. I often find just pausing a video and restarting can get rid of stutters or audio out of sync. Not ideal, but a workaround.

1 Like

Thank you, I appreciate you looking at it. It is clearly intermittent and I don’t rule out it being my TV (although it is a Samsung 4k).

There are a (very) few HDMI messages in there. You might like to try a different HDMI cable or squirt some contact cleaner in the ends.

1 Like