Choppy 4k playback on Vero 4k+, 1080p is fine

Hey everyone. All of a sudden, my Vero 4k+ has a problem with 4k content. Framerate gets very choppy (we’re talking 1 FPS here, maybe less), disabling hardware acceleration doesn’t seem to change anything. I tried a number of files, all of them ended up unwatchable.

No problems with the audio tracks though. 1080p playback is still perfectly smooth. I remember having similar playback problems once or twice before but after a while 4k playback worked again.

The device feels very hot very soon after booting. Any idea what’s happening? Here’s my log file.


Your device is falling to play these files and keeps closing and re-opening the decoder, hence the slow playback.

My suggestion would be to reinstall OSMC if possible, taking a backup first.


Hey Sam, thanks! Unfortunately, reinstalling OSMC didn’t help. Even in March update stock form the playback experience is exactly the same. Could this be a hardware problem? Thanks, Adrian.

No - shouldn’t be a hardware issue.

I’m going to guess that OK files are H264 and problematic files are HEVC. This could suggest a bad rip.

I did some more testing and it looks like the problematic one are all HEVC files it seems – but not all HEVC files (and, contrary to my first impression, not all 4K files) are problematic. Out of the the ten newest HEVC HDR titles in my library, eight were choppy, two were smooth. While it’s possible they’re all bad rips it’s pretty unlikely – there’s similar releases by the same groups on both sides.

I just tried a non-plus Vero 4K I keep around – the smaller files (where buffering is not an issue) play flawlessly, even the one I used for the log I provided.

Also, I just had a 4K YouTube stream sort of crash on me. The Image turned static green while the audio kept running. Navigating was still possible, everything’s back to normal after a reboot.

I have some ideas, will make some suggestions tomorrow.

Can you try a cold boot with the device off for a couple of minutes at the mains?

I already tried that. Yesterday I let the device sit without power through the day to make sure temperature isn‘t an issue. No change.

I’ve sent a test image you can try. It would be good to know if this solves things.

Thanks Sam! I’m happy to report that every file I tried plays flawlessly with the test image.

Great, those improvements will be made available soon in a general release.