Choppy and noisy audio playback after full reinstall and new raspberry pi NAS nfs share

After reinstalling my Vero 4K+, I rebuilt a new mysql database on my raspberry pi sql server and shared the usb hdds through the nfs share of the OpenMediaVault NAS running on the same Raspberry 4 Pi.

All looked nice, until I tried to play some music (hires flac and dsd stereo and flac multichannel files.)

The audio is fully out of sync, its like playing with 50% higher speed, and a continuous hissy noise is under the music. All this through the hdmi output, which worked perfectly before the full reinstall.

Video playback is also weird, sometimes the played video stops after a few minutes or the picture falls apart even with low res 720p Mkv files.

I connected to the same NAS with my windoes PC (smb) and it can copy files through the LAN with 50000 Kbps, so its not a speed issue, however I could not test the nfs protocol from the PC. But would be weird if nfs is slow, but smb works just fine.

Do you have any idea what else can cause these playback issues?

Upon of these new problems, sometimes I also run into a sad face when I simply want to click on one of the media shared HDD for browsing in the Settings/Media/Video shares. No error message but an immediate crash.


First try to play the file locally (USB Stick) to exclude the Network as a source of problem.

Upload (ideally debug enabled) logs after such a crash

I tried with an USB key, the music files were playing, except the stereo Dsf files (sacd format) it was choply and noisy. I tried the nfs connection to the NAS and none of the audio formats were playing right. Then I created a zeroconf SMB link to the same HDD to try with the smb connectikn, but when I wanted to clink on that link to browse the content, the sad face has arrived. :rage:
Event log file

Suggest to first check your network with iperf3

Thanks! I did the iperf3 test between my NAS and Vero 4k+, and the result was as expected on a wired gigabit network:
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-60.02 sec 6.53 GBytes 934 Mbits/sec 222 sender
[ 5] 0.00-60.00 sec 6.53 GBytes 934 Mbits/sec receiver

Meanwhile I created another share (smb) manually, and tried to play movies, music but maybe a slight improvement with some files, but definitely not good at all. I try to avoid switching from the NFS connection to the SMB again, when I started to rebuild my library the third time.
When copying a large movie iso file through my LAN to my windows PC with SMB connection, the copy speed is approx 25.000 kbyte/s, which should be more than enough for any file type. I can’t test the nfs speed with my pc unfortunately.

I found that the MTU setting is empty on my OpenMediaVault NAS software on Raspberry Pi (probably it means the 1500), however my Asus router supports jumbo frames. Just wondering if I should change it to 9000 or not?

Did you also tried the reverse direction and maybe for a longer timeframe.

To avoid such issues I suggest to use kernel mounts then you can change from SMB to NFS or have NAS changes without impacting your library.

Generally a 1500 MTU should be fine for your LAN.

yes, I tried the 60 sec test, same constant result. Also the reverse was very close:
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.00 sec 975 MBytes 818 Mbits/sec 0 sender
[ 5] 0.00-10.07 sec 974 MBytes 811 Mbits/sec receiver

I’m not an expert (yet:-) in this linux world, so can you please explain what is kernel mount, and how to do it on Vero? I already built half of my library with zeroconf NFS shares, what the Kodi found via search.

If the connection speed is perfect between my NAS and the Vero, the NAS transfer speed via SMB is quite OK between my PC and the NAS, then something fishy with my Vero. Since the database now on the SQL server, maybe a fresh and hopefully final install would be the next step?

Check these threads out

Thanks, I tried to follow the guide, but stucked at this point:
/mnt/ :</path/to/share1>
my NAS NFS share is coming with a port number, so its : nfs://
but this does not work:

Can you tell me, how can I add this to the automount file?
Thanks a lot!

That is the NFS standard port no need to mention it.

Thank you, now it works! So I have these autofs mounts on my first vero. If I make a backup and copy it to my second vero when it arrives, it will move these settings to the new one, or I need to do it again manually?

Now, I need to relink the library to these new shares, right? Any chance to do it without rebuilding the library again?

Or you suggest to try the file playback manually through these links, before going ahead?

Meanwhile I did a quick test with the new autofs shares, and it seems it can play 4K video files without any problem, and also most of my audio files as well. The only struggling file format is the DSF, the SACD hires audiofiles. They are still choppy, and cannot really play. Could it be a Kodi player issue then? Because it was the same issue from the USB stick.

Well you could just use path substitution (see below) but you may want to use this to also clear up the sources a bit.
But if you use mixed environment (e.g. your windows machine) with a shared MySQL Database you would need to use path substitution on one of the systems.

Yes you just would need to install autofs package but could just copy the config files.

Yeah if same issue on USB stick that should be another non network issue.

Thanks a lot for your help, very appreciate it! I decided to go ahead again, and rescan my library with these new shares to make life easier in the future (and avoid from any mess in my sql database). I hope this will solve all the playback issues.

Yeah good decision especially if you get a second Vero.
Just remember if you use the same shared Database from other device (Windows) you would need path substitution on that system (sorry forgot the info in last post).

If you would like to use a MySQL database for several Kodi clients that use different methods to access the shared media (e.g. a mix of SMB, NFS and/or system mount based access), or have need of modifying a path of an existing source (such as converting from a Kodi path to a system mount) you can use the path substitution function of Kodi to facilitate this. The following guide will provide instruction on how this works, including a section specific to MySQL usage and how your sources should be configured.

Please see [HowTo] Repairing File Paths with Path Substitution for details.