Choppy playback with Raspberry pi 3 B+

I tried setting up a kodi osmc client for my parents, but it is getting horrible playback frame rates.When I set it up last night it worked fine without any issues, however today the playback is very choppy. The debugger says I am getting 7-8 fps when a movie is playing. This happens across every movie/show I tried in Netflix and Plex. There aren’t many options to mess with and I don’t have a clue on why this is happening. I don’t think my pi is thermal throttling, even though it doesn’t have a heatsink atm it hits mid 60’s when streaming.

This is the guide I used to get everything set up. I’m not sure if the downgrade portion was necessary, but I went ahead and followed it to a T since I’m not very familiar with kodi or linux.


The 7-8fps is the refresh rate of the debug overlay; not the video itself.
If you’re using Netflix, you’re likely using a Kodi v18 build which is still experimental and not ready for daily use yet.

Ahh, makes sense for the debugger. For the Kodi build, I’m using 17.8-370

I would recommend staying with 17.6 (stable) for now.