Chromium won't connect to internet in X11 on RPi4

Hi there,

I’m new to this OSMC forum. I have no doubt that someone has already encountered this problem and it has been solved. But I’ll ask again anyway:-

I have used the following link from these forums and followed the instructions to get x11 running on OSMC on my RPi4:-

The good news is that after changing the https for http, it installed.
The bad news:- when I open the Chromium browser it doesn’t connect to the internet. All I see is “Aw Snap”.

There doesn’t appear to be any obvious way to get x11 to connect to the internet.
When I run Kodi, the internet connection is fine.

Does anyone know how to fix this?

@joakim_s May have some ideas. Have you verified network connectivity via My OSMC or System Info in Kodi?


First off, sorry for a late reply. I haven’t been paying attention to this addon the last few months, I have plans/dreams of where to go with it. But running into problems, which drains the time and energy I’m able to put into this little project.

My first guess was that the install script installs a very old version of chromium, due to my bad foresight, it only checks for Debian version “Buster”, anything else and it grabs an “old” Ubuntu .deb file. So I tried to install the desktop on a “clean Vero4k+”, but manually installed chromium.

This should fix your system:

sudo dpkg --purge chromium-codecs-ffmpeg-extra_68.0.3440.75-0ubuntu0.16.04.1_armhf.deb
sudo dpkg --purge chromium-browser_68.0.3440.75-0ubuntu0.16.04.1_armhf.deb
sudo apt-get update
sudo apt-get install chromium-common chromium chromium-sandbox

Purge command might need you to remove .deb, it’s 2:40 am and I have no time to test with those old packages installed, since I got it working with Bullseyes own Chromium packages.

ps. while I’m at it, changed the behavior of the installer too, shouldn’t be an issue now.

Hi joakim_s,

Thank you for getting back to me. Great news, I have Chromium working on X11 now.

The 2 sudo dpkg commands didn’t seem to do anything (even with removing the .deb), but
I still did the update and did the sudo apt-get install command you listed.

The result was 2 chromium browsers to choose from in the pull down menu. I found which one worked, added a shortcut to the desktop and removed the old one. Problem solved. Now I can continue to do guitar lessons via Fender Play using my TV.

Before OSMC I was using PiOS, but the latest version of Kodi available on PiOS is 17 Leia.
Some of the add ons I want to run wouldn’t work in Leia, so now I use OSMC.

It works much the same way as opening a browser on PiOS… exit Kodi to the desktop, open the web browser and go from there.

Again, thanks for your help. And thanks for devoting your time to do this project. I have a vague understanding of programming (and personally, I find it a P.I.N.A!).