Cirrus logic audio card

I have cirrus logic audio card on my rpi and it worked. today I updated the system and it stopped working. the error in the dmesg is:
arizona spi0.1: Failed to request DCVDD: -517

it seems that there is no arizona-ldo1 module compiled in the latest kernel while in previous kernel this module was compiled.

It seems you are correct.

osmc@osmc-pi3:~$ find /lib/modules -name arizona-ldo1.ko

Perhaps @sam_nazarko can explain why it’s not in the new kernel.

4.9.y is not the latest Pi kernel. It should be 4.14.

The issue is that the new kernel does not provide this module


Is it possible to reenable this module in osmc ? Cirrus card driver that is available in osmc is not usable without this module.


Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


yes, it works now. Thanks !