Clearing up apt archives


#1

My apt archives had almost 2.4Go of archives and i could not do anymore updates due to insufficient space.

Running apt-get autoclean solved the problem. I would recommend to do this by default as a lot people my get their archives filling up without knowing


#2

I think older kernels get cleaned at update.

Did you install a lot of stuff via apt?


#3

Well i have not installed that many programs via apt i did install some testing channels (like before krypton 17 was released as stable) they were made available made by Sam.


#4

That would have replaced large parts of the osmc userland everytime you installed a testbuild.

I have a system I never installed stuff from apt and I didn’t have to clear that cache for over 3 years.


#5

This is something that’s been discussed for some years in Debian. See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=160743.

I believe this has been addressed:

commit ee02b5b3949372a178d37cadaa08db0bfd5b991f
Author: Michael Vogt <mvo@ubuntu.com>
Date:   Sat Jan 2 22:08:30 2016 +0100

    Add new APT::Keep-Downloaded-Packages option
    
    This option controls if downloaded packages should be kept after
    a successful install or if they should be deleted. The default
    for "apt-get" is that they are kept (just like before).
    
    However the default for "apt" is that they get deleted.

We can then add an option to remove downloaded packages
after they are successfully installed. But it needs some more
thought.


#6

Bump on this very old thread after one year i am having the same issue.

df -h before clearing up archive

/dev/mmcblk0p2  7.0G  6.3G  299M  96% /

After sudo apt-get autoclean

df -h

  /dev/mmcblk0p2  7.0G  5.3G  1.4G  81% /

almost 1.2 g of old packages installed cleared.


#7

Are you updating via the command line or My OSMC?
Cleaning up archives via the command line has been fixed some time ago, but there may still be issues with My OSMC.


#8

I am mostly using myosmc addon. 95% of the time


#9

Ok — we will work on this issue.