Clone CB2 HDD to SSD

I manage to clone the drive’s two partitions (leaving out the unallocated space) by issuing the following command (I specified the last block of disk2 via count=):
dd if=/dev/disk2 of=/dev/disk3 count=49254400

The issue now is that I put in the SATA SSD (via ATA/SATA adapter). The boot starts but fails early. Can someone please tell me what/how I need to change to make the boot work? Heres the code:

Gave up waiting for root device. Common problems:
- Bot args (cat /proc/cmdline)
  - Check rootdelay= (did the system wait long enough?)
  - Check root= (did the system wait for the right device?)
- Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/sda2 does not exist. Dropping to a shell!

Busybox v1.18 some text
some text

(initramfs) _


I have a 300GB PATA HDD with CB2 on it. More specifically, it has the 50MB Apple recovery partition, 25GB CB2 partition and the rest is unallocated space.

Now, I want to clone the existing data to a brand new 30GB SATA SSD. I am using Mac OS X and I have both drives attached via USB. Can someone please (perhaps @wrxtasy) write what is the appropriate command I should type into terminal to accomplish this.

I must add that I first tried to do this by booting from Gparted LIVE USB stick and then manually copied over both partitions (Apple recovery and CB2). Even though the ATV1 booted, there was some kind of error. Thus I believe that I must clone the whole drive structure (except unallocated space).


   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *320.1 GB   disk2
   1:             Apple_Recovery                         50.0 MB    disk2s1
   2:       Microsoft Basic Data                         25.2 GB    disk2s2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *30.0 GB    disk3
   1:                        EFI                         209.7 MB   disk3s1
   2:                  Apple_HFS Untitled 1              29.7 GB    disk3s2

macbook:~ reinis$ sudo fdisk /dev/disk2
Disk: /dev/disk2	geometry: 38913/255/63 [625142448 sectors]
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
 1: EE    0   0   1 - 1023 254  63 [         1 -         39] <Unknown ID>
 2: AF 1023 254  63 - 1023 254  63 [        40 -      97617] HFS+        
*3: 83 1023 254  63 - 1023 254  63 [    102400 -   49152000] Linux files*
 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused

You need to edit your startup command to point to the right partition, I’m not really versed in the ATV so I can’t help more than that

Thanks for the tip. As I cannot boot CB2 I really don’t know how to change the pointer to the right direction.

Actually I don’t understand why this has happend because I cloned the drive via dd without changing anything in the drive structure. Perhaps the command above messed up something during the cloning process (no errors showed up, though).

Any help will be appreciated.

Like I said above I don’t know the ATVs The first thing to try/check is that the cloned drive is plugged into the same port as the original drive was. The OS assigns sda…sdb…sdc based on what drive is seen first and the port that it’s plugged into, the fact that you’re using a ATA/SATA adapter may change the assignment.

You can always use trial and error, try sdb2 then sdc2 You will need to mount the boot partition to edit the boot command (Not sure how ATV boots :slight_smile: ) Do you have a Linux pc? You can use a bootable USB stick, did you make a gparted boot usb or CD? you could use that if you did. Now I’m starting to ramble, sorry I can’t help more.

I have a Gparted Live USB that I can boot from. What commands should I issue to change the boot partition (trial&error)? Bt the way, as far as I know CB2 is Ubuntu 12.04 with custom kernel.


I did the clone via Live Clonezilla and it worked well. The SSD now have the CB2 clone on it.