Color banding in HDR on LG OLED C8

Honestly, and I can’t explain this, I tried again when I got home from work and the “ultra hd deep color” now works, no hiccups, and no loosing the signal. I can’t believe that I’m saying this, but it fixed itself, lol. I did however remove the “PC” input assignment as suggested.

Even so, it did not help. The video still looks the same. I’ve now done a new log upload and made sure it was correct this time (with the “force 422” option enabled):

I’ve run a few “10 bit patterns” from the same collection, and they all look fine, so I think you are right about that point. If the Vero would output 8bit color, I would expect a lot more banding than I’m experiencing too I guess. Movies and such in general looks great, and honestly, I can live with the current setup quite well, its just annoying knowing that something is not quite right somewhere down the line…

Maybe I’m looking at it the wrong way. Could there be something funky with the video files itself that make the playback go haywire?

Test patterns are designed to allow you to see things that would be hard to evaluate under real world conditions. It is generally important to understand exactly what a test pattern is designed to show show you. You would have to read through the documentation that comes with the patterns to know what you’re actually supposed to be looking at and why.

I have the same model and everything is so far perfect (1 and half year). Don’t use PC INPUT icon to enable 4:4:4 because there are no benefits at all with that setting, enable force 4:2:2 check may helps, just test it with some youtube HDR 4K test video you can download even from the producers’ website

Please mark the solution … as solved, there should be an option for that.

Yes, I know. I’ve only used a selected few patterns to check specifically for banding. The reason I started this process was that I noticed some minor banding in some scenes in the movie “The Revenant”, so I though I should check the HDR playback properly, hence the ramp patterns. What really triggered me, and this post in the first place, is the fact that the Vero plays them differently than the TV itself, the TV then being perfectly smooth as it should be, and the Vero output no so much.

Either way, the screenshot below is now how the vero greyscale ramp looks like. I’m not a picture wizard, but I’m pretty sure that’s not how it’s supposed to look?
(sometimes the Vero plays the video in a weird small box in the upper left corner too, but it seems random what it decides to do with this file)

I might add too that I’m really happy with all the good help and advice I’ve got so far from the community!

1 Like

Is your HDMI cable certified for 4K 60Hz? I’ve solved a lot of issues just changing my previous with a certified one. You could check everything starting with a fresh environment, like resetting TV to factory default as your Vero, then enabling Ultra Color on your HDMI port.

There are a few different things going on in this thread that are best understood if they are not conflated. First is the original banding that lead you start troubleshooting. Your TV was set for the Vero to give it 8-bit color and also to fake HDR for 8-bit sources. This is going make any banding present in your source file more noticeable because you are increasing the difference in luminance. When you play directly on your TV that is likely set to automatically switch to 10-bit and thus is going to look different than 8-bit fake HDR. Once you turn on the deep color for the Vero input then that is able to send out 10-bit and should look pretty much the same as the internal player.

As far as the test video wigging out, screen blanking, and moving to a portion of the screen, this is something that likely is being caused by something in the chain not supporting a higher bandwidth required by a setting, or switching to a video mode that is not supported by the TV. This can be a bit harder to understand as certain modes may only be supported at certain resolutions or with certain settings. It is best to read through the manual for the TV to get a good understanding of what it can, or can’t do, and then go into the settings in Kodi to match up what is supported.

What my TV can and cannot do its quite impossible to understand from the manual, as that would only give nonsense explanations with words thats probably made up to look somewhat fancy in the menus :wink: Thats why I’m asking here, to get the proper technical explanation to things… :slight_smile:

Anyway, I will get a proper cable to test first. Are there any special properties or certifications I need to look for, except just buying the most expensive one I can find?

I don’t really want respond to the previous comment other than to say I disagree. The internet is amazing in that you can search for explanations of terms and topics that you are not familiar with.

As to the cable, this is a debatable thing, and I probably should not actually say what i’m going to say next as someone will likely want to chime in on how wrong I am. The most expensive cable you can find is better suited to empty your wallet than give you any real benefit. My personal opinion is that if you are only needing <2m then a suitably spec’d cable from Monoprice or BlueRigger is more than adequate.

1 Like

For video up to 4k60Hz you are safest with certified ‘premium high speed’ cables. But there are lots of cables you can get without the certification, eg Amazon’s basics ‘high speed’. Amazon do say they support 18Gbit/s which does correspond to 4k60Hz and people in here have used them without issue. The longer the cable, the more quality you need to be sure of good performance.

Beware of cables marked ‘4k’ - they may only support 4k24Hz (10.2Gbit/s). Cables marked 1080p are a waste of space these days.


Definitely do not go by price. Look for one that is described as “premium high-speed” (the “premium” is important) and which has a 2D barcode image in the advert.

I had a quick look on Amazon just now, and this was the first one to come up:

but there are plenty of other options. When it arrives there should be a barcode label that you can scan and that will take you to the webpage of the certifying body…

For completeness, there are two situations where you may need to spend more money. One is if you need a cable that is particularly strong (for example if you need to be able to pull it through a cavity wall); the other is if you need a cable that is more than than 5 metres long. But I don’t think either of those applies here.

EDIT: I see Graham got in ahead of me. :slight_smile: Yes, Amazon Basics cables also have a good reputation. Personally I prefer to get something independently certified - that’s what the barcode is about. You won’t have any trouble with an Amazon Basics cable, though.

Try a real-world video example. Download this:

Check that the TV actually switches to HDR mode when the Vero is playing this (there should be a visible HDR symbol at the top right of the screen when it switches mode).

Then, at about 1m28s there’s a brief shot of the Taj Mahal; do you see very obvious, blatant banding in the sky behind/around the building? If so, that means your Vero is outputting in 8-bit for some reason.

You don’t have to wait for the Taj Mahal. The sky over the skateboarder a few seconds in is my yardstick.

Yeah, but then you don’t get to see the monkeys, and they’re cute. :laughing:

@sharkLazer, that video is also quite a good HDMI connection torture test, as it’s 60fps 4K HDR. If you have signal stability issues, try unchecking the “force 422” setting.

If you’ve figured out how to get into the SSH command-line you can also force 8-bit colour with this command (issue before the video starts playing):

echo 444,8bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

To force 10-bit colour, use:

echo 420,10bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

I suggest eventually rebooting after using either of those, to reset to default behaviour, or you may get weird results on other videos. But that should make the difference between 8-bit and 10-bit clear; and if the default behaviour looks like 8-bit, that may narrow things down a bit.

Actually, that won’t work unless the screen mode is already on 4k50/60Hz since 420 isn’t supported at any other resolution. But just

echo 10bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

will do the trick, or even

echo now | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

to reset to defaults (10 bits, 420 for 4k50/60Hz, 10 bits, 444 for everything else).

If Force 422 subsampling is active, restart Kodi (Power->Exit) for that setting to take effect after messing with attr.

1 Like

I suggested setting 420 explicitly because the specific video we’re taking about (World in HDR) is 60Hz, and because there are questions about the stability of his HDMI connection: 420 10-bit has a better chance of establishing a signal lock than 422 if something dodgy is happening, and if he’s following the advice higher up the thread he may still have the “force 422” option set in settings.

But in the general case, yeah, absolutely.

I actually didn’t know that, that’s useful. :slight_smile:

Sorry, my failed attempt on being funny. I’ve done a fair share of googling and research into different topics, I was merely replying to the statement “just look at the manual to get an understanding of your TVs options” which does not help any bit at all, as they never go in enough technical detail to be helpful in troubleshooting. If I have to google every other option in the menu to understand what its doing, I’d say the manual is not good enough :wink:

Thanks for the tip. I have ordered some cables from Amazon now to test.

That was a really good test video! I will keep this for for any future reference :slight_smile:

I did not however need to skip to the Taj Mahal shot, every scene with a horizon looks absolutely horrible. Large amounts of color banding. Especially that first skater scene.

I tried this now, but for some reason nothing changed and I could still see the banding in the video? Anyways, I will wait for the cables I ordered and try again.

Again, thanks for all the helpful input.

With Amazon Basic’s HDMI cable my connection between Xbox/PS4 and TV has always been unstable with flickering and sometimes intermittent black screen…just to say…

I’ve been looking into this. Those test files have a framerate of 1fps which is confusing Kodi when using Adjust refresh rate (and the reason for the small picture upper left). To use those testfiles on Vero, please turn off Adjust refresh rate, set the resolution to 4k24Hz, 4k30Hz etc and see what you get.

Yes, turned off the “adjust display refresh rate” option, and it worked straight away, thanks!

On another note, I got to borrow another HDMI cable (while I wait for the ones I ordered), and even though it does not seem to be working all the time, the banding on that test video is now gone! Perfect smooth gradients, and it might be a placebo effect, but I could swear the colors are better too!

So I guess I have to apologise for this long thread, its embarrassing to admit that it all came down to my HDMI cables… I’d like to thank everyone for their patience and good tips :slight_smile:

On another note, may I suggest shipping the Vero with a better cable? :wink: