Colors problem RPI4


Since several days I have problems with the colors of OSMC on my RPI4, it happened with the november or december update I don’t know.
The colors are too bright and when the resolution change when I play a video (this option was turned off before the update) the colors are too dark and stay dark even after I stop the video. I read a few topics on HDR but my TV is not HDR so I don’t know what happened during the update.

I tried with another SD card and reinstall the august update, the colors are normal.

With the last version (same settings, nothing was changed on the TV)

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Here the log :

I just tried to change the frame rate in the settings and I have the same problem. When I reboot the dark colors become bright again.

Before change the rate (too bright compared to the august update) :

After (too dark) :

I can’t quite figure what’s going on, but this may give you some clues.

Actually after a few tests, the colors after changing the frame rate is the same than before (the same I had in the august version), but I have to manually go in the menu to change the rate to have the good colors at each reboot.

It’s only at the start of OSMC and I just noticed after a few tests that this problem doesn’t happen with the other HDMI port of the RPI4. So now I’m using the other HDMI port (the closest to the power cable) and it seems working but I don’t know why.

I can confirm. I have the exact same problem. When the Raspberry Pi is connected to the HDMI 1 port, all colors are washed out when Kodi starts during boot-up. If I change the refresh rate or resolution, it seems that it fixes itself. This problem doesn’t occur on the HDMI 0 port.

Interestingly enough, it seems that when I power it on, the OSMC splash screen has the correct colors, but when Kodi starts, it switches to the washed out version. If I go to Power > Exit and close Kodi, as OSMC tries to restart it again, I noticed that this time, the OSMC splash screen is also washed out.

Not sure what the cause of the problem is, but is seems that it happens when Kodi starts.

P.S.: after doing the resolution/refresh rate quick fix, the colors don’t change when restarting Kodi. It seems it only happens once when booting up

Is there a specific reason you wish to use the HDMI1 port?


For me not specially, I just plugged one of the HDMI ports, I didn’t have a problem until this update. Now I know that I have to plug the first port.