Compute Module: OSMC installs, then blank screen on first boot

Hello All,

I’m trying to load OSMC onto the eMMC of the pi compute module. With the compute module seen as usb mass storage device on my laptop I use the OSMC installer tool, choose SD card for install (I believe I read the eMMC is connected via SD lanes on the compute?) and load the latest pi 1/zero

Upon rebooting the compute module attached to a monitor I can see the installer run through its paces and goes to 100%. It reboots and then nothing but a blank screen.

Am I missing a step?

Probably because target installer uses old SD driver but OSMC uses SDHost. I don’t think this is compatible with CM.

Does dtoverlay=mmc in config.txt help?

I will try and see if that helps. Thanks Sam.

Is there a recommended method to install OSMC onto the CM?

That did not help unfortunately Sam.

I think the Raspberry Pi Wiki has some information on loading an OS to the CM and how to use it as a mass-storage device.

I am not sure the OSMC installer is equipped for this task.

When you say that it did not help, did you edit config.txt post installation?


I tried it once pre, and that didn’t work, I also tried it post installation and that didn’t work.

I’ve gone through the wiki and that’s how I was able to get to the point of loading an OS. it just doesn’t seem to want to work.

Not able to tell what’s going on from this description.

You need to edit config.txt post-installation and need to make sure you do it on the right partition if using anything like NOOBS.

Ok, I’ll explain the exact details to date:

I plugged the compute module into my laptop with a carrier board. I ran rpiboot to allow the laptop to view it as mass storage. I used the OSMC installer (I did this from a Windows laptop and a Ubuntu laptop) to install an image directly onto the compute module eMMC.
After I ejected the compute module I repowered it up with the OTG power connector and the OSMC install page started and completed to 100%. It reboots and then just a blank screen.

I then took the compute module and set it as mass storage again on a laptop to edit the config.txt file, replacing the dtoverlay=lirc with dtoverlay=mmc and it didn’t help. I tried another time leaving the original dtoverlay=lrc… and adding a second dtoverlay=mmc, that also didn’t work.

Installed 2015.06-1 instead of latest and OSMC is up and running.

I’ll try again on a newer release in the near future.

Some interesting info here, I’m not sure why the dtoverlay=mmc wasn’t working for me: