Config.txt only can be edited from MyOSMC?

If I try to edit manually the config.txt file (local, ssh or inserting SD card in to the PC) I get a non bootable system. That’s a bit annoying because this method it’s too slow for doing try-error overclocking tests.

Installation is on USB stick, and latest version of OSMC installed

Well plugin the card into PC might give trouble because of the editor you might use.
Editing it via SSH is not a problem at all as long as you don’t write wrong values in there, I do that all the time.

Ditto. I always use ssh.

As I said before:

by ssh --> No boot
by “sudo nano” on the Pi --> No boot
by Notepad++ on the PC --> No boot
by SCP the file to the Pi --> No boot

Any other ideas for this behavior?

Maybe it’s not how you are editing it but what you are doing to the file.

1 Like

You may be malforming config.txt which would prevent booting.

I’ll tried to only comment a single line by putting # and still get the problem. The file cannot be edited.

I just installed another distro and i’m editing the file flawlessly, also configured full overclocking :-/

It depends what line you commented out. If start_x=1 gets mangled, then OSMC won’t boot properly. You can definitely edit config.txt manually.

You could show us config.txt values you are trying to use.

If the new distribution works fine, just use that.

What line?

I usually delete the line start_x=1 when configure the decode_MPG2 and decode_WVC1 lines. That’s what was wrong. My fault.

You need start_x=1 for OSMC to boot.