Configuring IR Remote with Technotrend TT-4600


I have just installed OSMC on Raspberry Pi 3 B and attached a DVB-S2 tuner to it (Technotrend TT-4600) and it worked out of the box without any driver issues but the remote does not work and I know it has no defects because it works under windows. Is there a tutorial to follow about configuring the IR Remote that came with the tuner itself.
I don’t have any problem to read, learn, and try before I post for help. I tried to find something useful to read about using “irrecord” but without any success.
One thing to mention is when I use “ir-keytable -t” there is a response and I know all the scan-codes for every button from previous trials to configure it under libreelec.

Best Regards

So if the IR reciever is working did you try to enable your remote via Settings -> MyOSMC -> Remotes?

But I need a working *.conf file to do that. So the first step would be to make the file then select it from Remotes menu.
I would like to add that I came to know after searching that I need to stop lircd_helper and then use irrecord so I tried the following:

sudo systemctl stop mediacenter
sudo systemctl stop lircd_helper@lirc0

then I started sudo irrecord -d /dev/lirc0 ~/my_remote.conf but there is no response
also I would like to mension that my remote follows the RC-5 protocol. I could have created the .conf file manually but I don’t know how to fill the header between begin remote and begin code.
I would really appreciate the help



I was able to use my remote finally using ir-keytable
What I did was I copied the working keytable in libreelec to my home directory and ran the follwing:

sudo ir-keytable -c -w ~/TT-4600
So I cleared the current keytable and loaded a new one and boom… It worked.
Not all the buttons were mapped correctly so I hade to install Keymap editor and adjust the keys that did not work, although the return button was the only one that I was not able to map. This is strange because this keytable works perfectly without any modification in libreelec.

I would appreciate if any one could please explain what is the problem with irrecord why it is not working for me despite the fact that i have stopped lircd_helper using lircd_helper@lirc0 and then tried to run irrecord -d /dev/lirc0 ~/myremote.conf but I ended with:

Hold down an arbitrary key
Timeout (10 sec), giving  up.

no noise was detected in the step prior to the timeout.

I would really love to map the remote using irrecord instead and make a conf file.


So I think I’m getting somewhere…
first of all I stopped the following:

sudo systemctl stop mediacenter
sudo systemctl stop eventlircd
sudo systemctl stop lircd_helper@lirc0
sudo systemctl stop system-lircd_helper.slice
sudo systemctl stop lircd_helper@event0
sudo systemctl stop lircd_helper@-dev-input-event0

I don’t know if some of these commands are redundant, I just applied all of them.

then when I ran ir-keytable this is the output:

Found /sys/class/rc/rc0/ (/dev/input/event0) with:
        Name: TechnoTrend TT-connect S2-4600
        Driver: dw2102, table: rc-tt-1500
        LIRC device: /dev/lirc0
        Supported kernel protocols: rc-5
        Enabled kernel protocols: rc-5
        bus: 3, vendor/product: 0b48:3011, version: 0x0000
        Repeat delay = 500 ms, repeat period = 50 ms

and then when I ran sudo mode2 -d /dev/input/event0 this is the output:

Using driver devinput on device /dev/input/event0
Trying device: /dev/input/event0
Using device: /dev/input/event0
Running as regular user osmc
code: 0x4d30dc61123c0d001400010032000000
code: 0x4d30dc61123c0d000400040051050000
code: 0x4d30dc61123c0d000000000000000000
code: 0x4e30dc61f7d101000400040051050000
code: 0x4e30dc61f7d101000000000000000000
code: 0x4e30dc6194b80d0004000400510d0000

and after pressing ctl+c I started sudo irrecord -d /dev/input/event0 ~/temp.conf
I used temp.conf because at first I want to creat the conf file from scratch without the help of any template and at first irrecord asked me to keep pressing a key

Enter name of remote (only ascii, no spaces) :tt4600
Using tt4600.lircd.conf as output filename

Hold down an arbitrary key
Found gap (259967 us)

Please enter the name for the next button (press <ENTER> to finish recording)

and after that I started to record 5 keys just to try it, and this was the output:

begin remote

  name  tt4600
  driver devinput
  bits           16
  eps            30
  aeps          100

  one             0     0
  zero            0     0
  pre_data_bits   112
  pre_data       0x400040000
  gap          259967
  toggle_bit_mask 0x0
  frequency    38000

      begin codes
          KEY_OK                   0x0D4F
          KEY_UP                   0x054D
          KEY_DOWN                 0x0D51
          KEY_LEFT                 0x054E
          KEY_RIGHT                0x0D50
      end codes

end remote

I don’t really know if it is correct or not but any way copied it to /etc/lirc and selected it from my osmc->remotes and rebooted. It did not work.

As a seconed try I tried to record based on a conf file from the same manufacturer that I found in the LIRC remote database online and which I copied it to a file and named it tt3600.conf and ran sudo irrecord -d /dev/input/event0 ~/tt3600.conf and this was the output:

begin remote

  name  3tt4600
  driver devinput
  bits           16
  eps            30
  aeps          100

  one           838   838
  zero          838   838
  plead         940
  pre_data_bits   112
  pre_data       0x400040000
  gap          107304
  min_repeat      1
#  suppress_repeat 1
#  uncomment to suppress unwanted repeats
  toggle_bit_mask 0x800
  frequency    38000

      begin codes
          KEY_OK                   0x054F
          KEY_UP                   0x0D4D
          KEY_DOWN                 0x0551
          KEY_LEFT                 0x0D4E
          KEY_RIGHT                0x0550
      end codes

end remote

Same thing I did and copied it to /etc/lirc and selected it from my osmc->remotes and rebooted but it didn’t work either.

Here is my LOG after I kept the conf file generated from scratch and selected in my osmc->remotes LOG

Please If anyone could tell me what I’m doing wrong I would appreciate that