Configuring remote control? / Remote not found

hi folks,

i’m setting up my new raspberry pi 2 with OSMC, now. but i can’t figure out how to configure my tv remote to work with osmc.

i have a philips tv 32PFL7862D that claims to have HDMI-CEC and a remote where you could even switch the devices it controls.
but it doesn’t react in OSMC at all. i tried different lirc presets (and downloaded 2 from the lirc site) but no reaction at all. plus, i don’t even see the newly downloaded ones when i select them in the “browse” window.

hopefully you can help me with that :slight_smile:

thanks in advance for even reading that stuff :wink:


CEC is enabled by default in OSMC and requires no intervention on it’s side. Try the TV menus to see that it’s been recognized and attempt to select it.

Also try a different HDMI cable if the TV doesn’t “see” a CEC device. Some HDMI cables especially cheaper ones do not work with CEC or do not work reliably.

You must also make sure that the TV is turned on before the Pi, unless you use a custom EDID file.

thank you very much for your answers…

i can’t find anything about my remote or about any connected device in my TV’s menu.

and i tried my 3 hdmi cables that i have in stock. didn’t work - but they were all cheap :wink: at least, with 1 cable, the visible picture has been detected automatically, but still, the remote didn’t work.

so, you say, the remote should just work without doing anything in the MyOSMC > remote menu (or anywhere else)?

do you have any other suggestions how to bring my remote to life? :smile:


No you don’t have to configure anything in OSMC to use a CEC remote - it will work out of the box. On a Phillips TV it is apparently called “Easy Link” - do you not have anything about Easy Link in any of your TV’s menus ? If not, it doesn’t support CEC.

1 Like

I had the same problem - tried a different cable & the remote just worked. Definitely check that your cable supports CEC - it’s relatively new in the HDMI standard & older cables usually don’t.

thanks again for your answers :smiley:

when i look into the tv’s manual, i just see CEC (no “easy link”). but it’s not in the menu where it should be. maybe the menu is just visible when the tv recognizes a device??

i just ordered a better cable (or at least one that claims to have CEC support)… let’s wait for that.

as another option, i’ve got an old USB IR dongle from technotrend (ttusbir) that i used with lirc a few years ago. maybe i’ll give that a try. but i only find how-tos for flirc instead of ttusbir. but if i’ll go with that, i should open up a new topic, anyway.


ok, cable was delivered… didn’t work. seems, that old tv doesn’t do the trick even though the manual says so :confused:

thanks again for your help. now, i’m trying the other option with the old USB IR dongle :smiley: