Configuring Transmission and Flexget

#1

Last year I set up my old AppleTV 1 with OSMC, Transmission and Flexget. It took quite a bit of tinkering to get it all working, but I eventually got it sorted out. Everything worked like a charm until a few days ago, when I updated my system from the command line… and clicked through the prompts that asked me if it was OK to remove OSMC without reading them carefully. I did a fresh install of OSMC but now I can’t remember how I solved all the issues I faced setting up Transmission and Flexget and I have not had much luck in finding the information online again.

Could any kind soul remind me how to deal with the issue that needs to be resolved before Transmission is usable? I understand that the download folder needs to be configured to belong to the correct owner and group, but I’m at a loss as to what those are. Similarly, what permissions should be assigned to the folder?

I have distant memories of facing similar problems with owners and permissions when setting up Flexget.

I obviously should have taken notes the first time round, but I suppose we live and learn.

I understand that the current build for AppleTV 1 will not be updated, which is fine by my as it works well enough for my purposes (or did until recently!). Thanks in advance for any input.

0 Likes

#2

I read that someone else did an ATV upgrade to stretch - but stopped at the critical moment…

I checked on the OSMC (jessie) repo and there is an i386-transmission-app-osmc package, which I assume is the one for ATV.

The OSMC version of transmission daemon runs under user osmc, group osmc, so if your download directories are owned by these, you should be good to go. If you find any issues, of course raise them here.

Unfortunately, I have no knowledge of FlexGet.

0 Likes

#3

That’s a very helpful response, thanks. Strangely enough, the OSMC app store never worked for me: I can see “Transmission Torrent Client” and click “Install” in the dialogue that appears, but then only “Apply” and “Exit” can be selected (“Install 1” is skipped over). If there was another way to install the app store version, I would gladly do so (I wonder is it available through apt-get as well as through the GUI?).

I have a feeling that my troubles the last time round stemmed from the fact that the regular transmission client runs under user “debian-transmission”. If it ran under user “osmc” group “osmc” I think I’d be home and dry.

0 Likes

#4

Yes. The only question is whether i386-transmission-app-osmc is the correct package for the ATV. Given that the ATV runs a Pentium, I’d guess that’s probably a Yes.

I suspect that’s why there’s an OSMC version in the app store.

0 Likes

#5

Thanks, that was really helpful. Your post pointed me towards instructions on this forum about how to add this package (for the benefit of anyone else who has the same issue later and stumbles upon this thread):

sudo nano /etc/apt/sources.list

Add

deb http://apt.osmc.tv jessie-devel main

and save the file.

Now, run sudo apt-get update

sudo apt-get install i386-transmission-app-osmc

I can verify that this version of Transmission works perfectly on the Apple TV 1 with no modifications to the settings needed. Now to get Flexget working again…

0 Likes

#6

After a little experimentation, I am back in business with Flexget too! Again, for the benefit of anyone else who might be interested in setting this up, the extra steps I took were:

Make the “.flexget” folder owned by user osmc, group osmc

Add the “python-transmissionrpc” package that flexget looks for:

sudo apt-get python-transmissionrpc

0 Likes

#7

You shouldn’t need to change to the devel version to install Transmission.

Sam

0 Likes

#8

Hi Sam - thanks for this input. I wonder if you could share what the preferred way to install Transmission is? I may have misunderstood something.

0 Likes

#9

You can grab it from the App Store.

0 Likes

#10

Thanks, but the OSMC app store has never worked for me on my Apple TV 1. I can select Transmission but then the “install” button is greyed out. This is why I had to revert to using apt-get to install it.

0 Likes

#11

Installing the app-osmc package is the same, so will work fine
Update capabilities were removed in the last update to prevent people upgrading to Stretch which isn’t officially supported.

0 Likes