Configuring TVHeadend on Raspberry Pi 1

Hello guys, I know I’m a couple of models behind but I’ve had my Raspberry Pi a couple of years now. I finally decided to make use of it and use it as a media centre. So I managed to get OSMC running, got a reliable wireless adapter. (TP-LINK TL-WN823N N300)

My problem is installing TVHeadend. I have tried to pick and unravel numerous ways to install and get TVHeadend working… to no avail. There seems to be numerous ways and I think I have got a little confused! :frowning:

I was wondering if there is a way to start with TVHeadend again and if someone could point me in the right direction in terms of getting TVHeadend working?

Thanks, Allen.

I assume you are referring to TVHeadend Server, or?
Well the right and foul proof way is to go to the OSMC App Store and install it with one click.
If you have tried other ways before I suggest you start with a fresh install of OSMC

I installed it initially from the App Store. Then the TV adapter doesn’t appear in the list on the TVHeadend UI on my comp…

Well is the TV adapter generally supported by OSMC? What’s the output of dmesg?

What am I looking for when I enter dmesg?

Well any entry that shows your TV Adapter and shows if e.g. Firmware is loaded.
You also can post your logs for review with grab-logs -A and post the URL

I know these maybe basic questions. I’m not currently on my Pi. If the firmware isn’t loaded, how do I do that?

First figure out the exact type of your TV adapter and then check for instructions on linuxtv

Oki doke. Well the adapter is the one I listed earlier, TP-LINK TL-WN823N N300. I will have a tinker later and will report back.


Either you are mixing something up or I get you wrong for the last 8 posts but that is your WiFi adapter and not your TV adapter

Perhaps OP is trying to do IPTV?

Right, am I missing a trick here? I am struggling to install firmware on the TV adapter… the missing firmware is:


Help please?

But what you quote above “TL-WN823N N300” is a wifi and not a TV adapter.

So you mean that you have one of these adapters?
It is used on the DVBSky T9580, TBS6281, TBS6285, Mystique SaTeCaBiX and PCTV 292e Triplestick (also contains EMPIA EM28174 controller)

Can you post the output of grab-logs -A

Logs are here:

Starting to get frustrated with it now… :frowning:

So it seems that the firmware for your tuner is not found

Nov 06 19:00:50 OSMC kernel: si2168 3-0064: found a ‘Silicon Labs Si2168-B40’
Nov 06 19:00:50 OSMC kernel: si2168 3-0064: Direct firmware load for dvb-demod-si2168-b40-01.fw failed with error -2
Nov 06 19:00:50 OSMC kernel: si2168 3-0064: Direct firmware load for dvb-demod-si2168-02.fw failed with error -2
Nov 06 19:00:50 OSMC kernel: si2168 3-0064: firmware file ‘dvb-demod-si2168-02.fw’ not found
Nov 06 19:00:50 OSMC kernel: si2157 4-0060: found a ‘Silicon Labs Si2158-A20’
Nov 06 19:00:50 OSMC kernel: si2157 4-0060: Direct firmware load for dvb-tuner-si2158-a20-01.fw failed with error -2
Nov 06 19:00:50 OSMC kernel: si2157 4-0060: firmware file ‘dvb-tuner-si2158-a20-01.fw’ not found

So suggest to follow the instructions that are listed on this page in the firmware section
To copy the file into /lib/firmware you would need to use sudo cp dvb-*-si2158*.fw /lib/firmware/

Do I put the link to the firmware in between the stars in the command line? And what do I do after that?

Seems you need a step by step help.

  1. Login your OSMC via ssh (if you don’t know how, check the FAQ)
  2. wget
  3. wget
  4. sudo cp dvb-demod-si2168-02.fw /lib/firmware
  5. sudo cp dvb-tuner-si2158-a20-01.fw /lib/firmware
  6. I all commands ran successful reboot

I’m getting this now after following your instructions…

I’m getting firmware is invalid…

Seems it wants a different firmware
Nov 08 20:49:28 OSMC kernel: si2168 3-0064: please install firmware file ‘dvb-demod-si2168-b40-01.fw’

Download that one and see if it works

I have downloaded the following firmware:


And got this dmesg:

I can’t figure what’s wrong or what I’m doing wrong here. I followed your instructions. :frowning: