Confiiguring Wifi on Apple TV

You did not upload dmesg output


@sam_nazarko: sorry sam. here is a log file with just dmesg

wlan is found in dmseg :
b43-phy0: Broadcom 4321 WLAN found (core revision 11)

in another thread here ( Enable wifi under GUI - #3 by ActionA) were 2 ways how to activate wifi if wlan is found.

i sshed into apple tv but i got the following errors:

osmc@osmc:~$ sudo cat/var/lib/connman/settings
sudo: cat/var/lib/connman/settings: Kommando nicht gefunden
osmc@osmc:~$ ls
Movies Music Pictures TV Shows
osmc@osmc:~$ connmanctl
Error getting VPN connections: The name net.connman.vpn was not provided by any connmanctl> connmanctl>agent on
Error ‘connmanctl>agent’: Unknown command
connmanctl> ls
Error ‘ls’: Unknown command
connmanctl> services
*AO Wired ethernet_0017f2f8a9dc_cable
connmanctl> enable wifi
Error wifi: Method “SetProperty” with signature “sv” on interface “net.connman.Technology” doesn’t exist

connmanctl> scan wifi
Error /net/connman/technology/wifi: Method “Scan” with signature “” on interface “net.connman.Technology” doesn’t exist

connmanctl> technologies
Name = Wired
Type = ethernet
Powered = True
Connected = True
Tethering = False
connmanctl> exit

Those instructions for configuring the wireless adapter are from before there was a gui. No need to do that.

If you look further down the dmesg log, you see the following:

Broadcom 43xx driver loaded ERROR: Firmware file "b43/ucode11.fw" not found ERROR: Firmware file "b43-open/ucode11.fw" not found

As Sam suspected, the driver is there but the firmware isn’t installed

Firmware will be included in update after testing.

nice, that are good news!

sorry for all my questions but is it difficult to install the firmware by myself before a new release of osmc?

i found the fw files but don’t know how to install them with “terminal”. on askubuntu there was guide, looked not to difficult but it was for another system, so useless for atv

I am not 100% sure as I don’t own a ATV but I guess it should be /lib/firmware/

If somebody is looking for a working USB adapter …
I tested OSMC yesterday and TPLink TL-WN722N worked out of the box, just insert your password and you are ready to go!
Very cheap dongle with a rock solid signal.

It’s pretty easy to install the broadcom firmware and get the card running. I put my ATV on a wired connection and SSHed into it (but you could probably use the local terminal or a spare wifi dongle). Then just use the following commands:

apt-get update apt-get install firmware-b43-installer

(Maybe you need to do sudo su first, can’t remember)
Worked for me, now I’m using the internal wifi card. Only weird thing is: I can’t connect to any n-only wifis, had to setup my router to b/g/n for the card to connect.


The Apple TV was released in 2007, and the N standard was not ratified until 2009 - are you sure it even supports N ?

That’s what I thought as well. But according to apple it does support wireless N. See also:
Apple TV 1 Specs
This would be consistent with the BCM4321 wireless chip that is installed in the ATV.
Just found an old thread that said that the b43 driver can access N cards but can’t use them in N mode. Can anyone confirm if this is still the case?

The spec page you linked to also says:

6. Based on an IEEE 802.11n draft specification. Learn more about the 802.11n draft specification.

A lot of devices were made to “draft specifications” before N was formalised in 2009. A lot of them could not interoperate with each other and they usually cannot interoperate with the final N standard unless a firmware update was performed.

There were some Macbooks that were released in 2008 which also had draft N support which later had to be updated to the final N specification using a firmware update. (Which Apple charged for!)

So if it is still using draft N it will not be able to connect to todays modern N access points. As the slot is a standard PCI express slot there is nothing to stop you fitting a modern wifi card in its place provided OSMC has driver support for the card, although if you are running OSMC it’s generally recommended that you use the slot for a Crystal HD card for much better video playback.

Yes, that might be the problem. And I am well aware of the CrystalHD card but I’m really just using the ATV to tinker around with and sometimes play back some non HD videos at my parents house. So im perfectly fine with it not having a CrystalHD card and with it not connecting to wireless N. All good :slight_smile:

I posted a request in the Feature Request section of the forum. Perhaps if we can show enough interest for it, It could be added. :neutral_face:


I’m new here and just started using OSMC on my ATV1. The ATV1 is in original state with latest software.
I use USB version of OSMC, latest version as well.
Problem: the wifi card is not found, only Ethernet.
What is wrong? Please give me a solution!


1 Like

I hope you are still able to read thru the thread in which you just posted. The issues of the internal wifi are clearly mentioned and a couple of replies YannickD actually said how he got it working

Thanks, I managed to work it out!

this worked fine with sudo su first, thx a lot


From what I see in this forum the solution is very simple.
Install the usb image on your apple tv
download the hdd image and then transfer it by sftp to Apple TV with filezilla or similar
then ssh to AppleTV and do sudo dd if=OSMC_TGT_appletv_20151123-HDD.img of=/dev/sda bs=4M
reboot taking out the usb stick
then ssh again and install the wifi firmware as above.
And you will have an working HDD OSMC AppleTV


Did this and it worked perfect. Thank you for the easy fix.

1 Like

Unfortunaltey NOT 100% perfect for me. All OK for 2.4 Ghz connections. BUT I am unable to connect to the 5 Ghz (N) band listed in summary of available access points.
lspci : Network controller: Broadcom Corporation BCM4321 802.11a/b/g/n (rev 05)
lshw -C network : … description: Wireless interface … configuration: broadcast=yes driver=b43 driverversion=4.2.3-7-osmc firmware=666.2 link=no multicast=yes wireless=IEEE 802.11abg

Driver appears to support only 802.11abg - anyone got the 5 Ghz (N) channels (driver) to work on OSMC?
Any idea what could be wrong?
Thanks :slightly_smiling:

The Apple TV is from 2007. 802.11a/b/g/n is all you’ll likely get.