Connect to Express VPN from OSMC - HELP!

Hi,

I am new to osmc / vero 4k world.

Trying to set up vpn connection on the new device and having a tough time doing it.
I tried to install open vpn - import the script method without editing any .openvpn cfg files as the structure of my cfg file is different from what is given in the tutorial from brian hornsby. it failed. I turned on the debug log but i don’t know what option to select and share the log within My OSMC - Log Uploader. I reckon because my set up steps are done correctly it may be obvious to you guys but i find this really hard.

I wish this was simple for normal users :frowning_face:

I then came across this Zomboided VPN Manager for Open VPN add on which looked like a life saver and tried to set it up. it did go to the final step and i am getting an error after selecting .ovpn file.

Any idea if I am doing anything stupid in this case ?

My vpn account is active and works fine on windows when checked.

Really appreciate if you can jolt down step by step instructions on how to install and connect to vpn from vero 4k. Its just been 2 days since i got this and because this is so hard i am very disappointed because it kind of feels this device is only for power users.

hope you can help me make it work to change my perception about it.

Try Brian Hornsby Addon, search this forum many references

1 Like

It is, you just need to follow the link you were given when you joined the forum:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

From your screenshot, its says AUTH_FAILED.

Make sure the username and password is correct in zomboided vpn manager. Click on the show password option to check. Make sure capitals and such are entered correctly.

Sure. There is no manual username and password apart from in the wizard after you select the provider. Post that I just used .ovpn cfg file which is provided by Express.

So where is the question of wrong password ?
I am not sure there is any need to edit the cfg file ? Wizard did not mention of that.

Ensure that the auth-user-pass in the config file is pointing to the correct fully qualified location. You can see it in the screenshot.

Thanks. By config file you mean .ovpn file?

From various youtube videos I saw that use Zomboided addon not a single one of them shows use of any config files. All they do is just install Openvpn and Zomboided add on. Put in user credentials and connect. In my case I authenticate ok and then it asks me to do the first connection where I select the server. It is after this step is expecting some crt, key, pass, .ovpn files which none of the videos have showed. So I am confused as to why its only coming up for me? Once this comes up because I don’t have a choice i select the specific .ovpn file and there you go this error comes up.

So when you say point something I am confused as none of the Zomboided users have done any pointing if you know what I mean?

I do have the .ovpn file for one server only. I downloaded from ExpressVPN’s own website from Manual - Open VPN as I didn’t find a specific one for OSMC. There are different ones for Linux, Raspberry but this one said open vpn so I downloaded this. not sure if these are the right ones?

Yes. Have you checked if it’s the correct file path?

You could try ask zomboided himself over in the libreelec forums (i’m not sure if he has osmc account). i see few other people having problems with expressvpn on there.

Ok. I have fixed this. Finally.

I believe it was an issue with missing zip file which ExpressVPN provides that contains the key, user, crt files. This is mentioned as optional in their website so I didn’t bother downloading it. Now I put it out in the same folder which had the .ovpn file (which I didn’t edit at all) and the whole thing just worked .

Hope this helps someone who is looking to do the same.

Can someone please fwd some info on installing Expressvpn complete with added procedure adding the user key and certificate files? Iam relatively new to this and still trying to figure out where and to install these files. Thank you
Bryan