Connecting to eduroam (WPA2 enterprise) or use university VPN

Hi everyone,

I know that WPA2 enterprise is not officially supported by OSMC, and will not be for a while, but I live in a university campus and I don’t have my own WiFi network.

I’ve seen that someone apparently manage to get eduroam to work with OSMC, but I’m struggling. Here is what I’ve tried:

I’ve created via ssh the file /var/lib/connman/wifi_eduroam.config, and I’ve written the following in it:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=<username>
Passphrase=<password>

I rebooted OSMC, but I still can’t connect to eduroam. I know that I’m missing something, but I’m completely new to OSMC, and feeling a bit lost. Anyone has an idea?

Alternatively, my university (Oxford) has a network to which one can connect via the uni VPN (Cisco): http://help.it.ox.ac.uk/network/wireless/services/owl/vpn/index
I have no idea if it’s possible to do that with OSMC, but if it is any suggestion is welcome!

My very last possibility to connect my Pi 3 to internet would be “The Cloud”, an open WiFi hostpot (https://www.thecloud.net/), but this requires signing up in a browser and I’m not sure how I could bypass this step.

Many thanks in advance!

connmanctl might have some information about this.

Try adjusting your config slightly.

[service_eduroam]
Type = wifi
Name = eduroamwifi
SSID = eduroam
EAP = peap
Phase2 = MSCHAPV2
Identity = emailaddress
Passphrase = password

Also remember your Identity should be your full email, not username.

1 Like

You can also use command line approach, i.e. ConnMan - ArchWiki which should work for you and create the service.

Many thanks! That’s very helpful. I will try to modify the config as you suggested. Could you explain to me how I could connect to a WPA2 enterprise password with the command line approach you pointed out? Many thanks in advance!

It’s in the link above

Sorry, my question was how to connect to eduroam with connmanctl once I’ve done the config, since the link doesn’t go into details: do I just do connmanctl connect with the eduroam network? Apologies for my naive questions, I’m rather new to linux.

I haven’t tested this, but yes, you want to turn on the agent, then try connmanctl connect.

Thanks a lot. I’ll report back!

Were you able to get it to work? I am trying to do exactly the same thing. I do not have any experience with Linux ro the raspberry pi, and all I want to do is get OSMC running with my university WiFi.

I have created the .config file as described above, in the location:
/var/lib/connman/wifi.config

I am still having trouble connecting to the network. What’s the next step?
(complete beginner here)

Hi! Unfortunately, I wasn’t able to do it. Some people have succeeded with other OS on a raspberry pi, but with OSMC I don’t know how to do it.

I hope reviving this thread might prompt someone to give a solution.

Perhaps this information will help you to set up your connection to the eduroam wifi network
Connecting a Raspberry Pi to eduroam wifi

Thanks, but this is not with OSMC. It is indeed fairly easy to connect to eduroam with Raspbian for instance.

1 Like

The link from puk78 mentions downloading a script. No logon was necessary, so here is one chosen at random for The Open University: https://cat.eduroam.org/user/API.php?action=downloadInstaller&lang=en&id=linux&profile=1943

If you go to the bottom of the script, you’ll see that key_mgmt=WPA-EAP, and, as already mentioned, WPA enterprise isn’t supported in OSMC. You’ll also find a host of other parameters listed that might be of use in setting up a connection.

Since very few people here are in a position to experiment with connecting to Eduroam, I suspect you’ll unfortunately need to do a lot of the spadework yourself.

1 Like

I have no background with software or coding or anything like that. But by just using trial and error and a bit of logic, I managed to get it to work.

The steps you took were on the right track, but the main difference was the SSID. I had to change it to what seemed like part of the full detailed name that shows up under connmanctl services list.

For example, when using connmanctl to see the available services, if you get this:

$ connmanctl services
*AO MyNetwork wifi_dc85de828967_68756773616d_managed_psk
wifi-one wifi_dc85de828967_38303944616e69656c73_managed_psk
eduroam wifi_dc85de828967_3257495245363836_managed_ieee8021x
wifi-two wifi_dc85de828967_4d7572706879_managed_wep

Then, this is the .config file you have to create. I just named it wifi.config

[service_eduroam]
Type = wifi
Name = eduroam
SSID = 3257495245363836
EAP = peap
Phase2 = MSCHAPV2
Identity = emailaddress
Passphrase = password

And then when I tried to connect using connmanctl using the “connect” command, it managed to connect to the network.

4 Likes

Thanks! I’ll try this method as soon as I get the chance. Are you able to get a consistent connection?

Yes, the connection is really good. Had it up and running the whole day yesterday and it went through multiple reboots.
You can confirm that the values mentioned below are set to “true” under connmanctl services as described in Connmanctl Cheat Sheet · GitHub

Favorite = true
AutoConnect = true

This should help with not having to go through connmanctl on every startup!

Hi again,

Thanks for your help @Abhi!

I’ve finally had a chance to try your solution, and my problem is the following. I’m accessing OSMC’s command line via ssh on my mac, by sharing my phone’s connection — since I only have eduroam wifi and no ethernet access. However, as soon as I use the connmanctl connect command to connect to eduroam, it disconnects the ssh, but fails to connect to eduroam. How did you get around the issue?

Specifically, is there a way to make OSMC autoconnect to eduroam upon booting, so that I can just reboot the Pi? You said that you’ve achieved this, but I haven’t managed to do so.

Here is what I’ve done:

  1. I have created a wifi.config file in /var/lib/connman/ following your instructions, with my eduroam’s SSID.
  2. I have checked that the settings are “True” for “Favorite” and “AutoConnect”
  3. I have rebooted my Pi, to no avail.

The problem may be that my Pi detects other WiFi networks (such as TheCloud), and tries to autoconnect to them rather than eduroam? Or maybe I need to do something else in order for it to take the wifi.config file to be the default config?

Thanks in advance!

Hi @steadyraph ,

Have you tried to use the terminal window within OSMC rather than using SSH when attempting to connect using connmanctl? You can enter it by hitting ESC once you exit OSMC from the main Kodi homescreen. This may avoid the issue of having to disconnect from SSH to connect to eduroam
You could also try to go to the networks page within the GUI of OSMC, disable and re-enable the wireless adapter. Then select eduroam to connect and if the details in the .config file is correct, it should be able to connect without having to enter any details. I have tried this and it works for me.

One of the things that threw me off a bit was, my uni email id ends with @aucklanduni.ac.nz but in order to connect to eduroam, I have to use @auckland.ac.nz
So check to make sure that all the required settings are accurate. http://help.it.ox.ac.uk/network/wireless/services/eduroam/index

Let me know how you go. Curious to see what makes the difference.

Thanks so much! I’ve managed to connect through the local terminal window (it was a bit of a pain with my mini keyboard remote). I’ll try connecting through the GUI as you suggest next time it disconnects.

Awesome!
A wireless keyboard with a touchpad can be a wise investment if you do anything with the pi.
I recommend either:
https://www.microsoft.com/accessories/en-us/products/keyboards/all-in-one-media-keyboard/n9z-00001
Or
http://www.logitech.com/en-us/product/wireless-touch-keyboard-k400-plus