Connecting with Windows 10

Hi there,

I’ve just got OSMC running on my raspberry pi2. Playback for local files etc is working fine. But I want to connect to my Windows 10 PC and can’t seem to through the usual add files, Windows connection thing (is it SMB?).
When it comes to username and password, I’ve tried giving it that, which is my Windows log in. I’ve also tried removing the username and password. Still no luck. I’ve tried putting in my computer’s IP address, but something weird seems to be happening there - it lets me do the 192.168 but then when I get to the next set of numbers, it wants more digits than are there. It wants two digits when my IP address only has 1 in the next set of numbers.
Can anyone help? As you can tell, I’m very much a n00b so will need basic explanations!
Thanks in advace,

There had been several threads around issues with Windows 10. Search the forum! One is this one Updated my PC to win 10, now OSMC can't see shared files

While I believe you just could enter a single digit and jump to the next field. But otherwise just use “0” as filler e.g.

Thanks for the response. I did previously find that thread, but those issues were to do with previously existing connections, not having issues with creating a connection in the first place.
Anyway, I did try to follow those instructions, but can’t seem to get it to work or with your instructions for having 0 as a place holder in the IP address. I am a massive beginner to this, so really sorry for not getting something that is probably blindingly obvious.

I’ve gone in to add videos, clicked browse, then gone into Windows network. I click on workgroup and owner-pc and get this page. I’m not sure if I should put I. The IP address here (which doesn’t seem to work) or what. Ive removed the username and password from my pc in case that was messing things up. Any ideas?

You need to enter the username and password of an account on your Windows PC that has access to the files you are sharing.

The IP address you don’t need to enter as you already have chosen the destination “OWNER-PC” as long as that is the PC you want to access then you are on the right way.
But you need to enter a username/password