Updated my PC to win 10, now OSMC can't see shared files

Updated my PC to win 10 today and that went ok. But then I wanted to relax and watch a show on my media center and all I got was errors.
The OSMC is installed on raspberry pi and all the media files are on my PC, After the windows 10 update my PC has never been better but my Pi is acting strange.
The OSMC does not see my shared folders and gets error if I try to access (error:invalid argument & Could not connect to network server)
If I try to add a share folder then I get Error 2: share not avalable when I select Windows network

I tried updating it but got an error (Error installing:unknown package).
*edit updating my raspberry atm, found the proper command

I would check the shares still exist on the W10 machine, along with checking the permissions on the folder.

2 Likes

I figured it out, thanks to CaNsA pointing me in the right direction.
I got it working after I selected the folder (in Windows) -> sharing -> specific people -> add ‘Homegroups’ to list of people
On the Pi: video -> files -> select folder -> Edit source -> add network location -> here I had to add the specific path to the folder, something like smb://ENTER_PC_NAME_HERE/name_of_folder

hope this helps if someone else has similar issues

I’m having very similar issues to the problem you described in your first post. So I tried adding my windows folder to Homegroups and adding the the folder using the “add network location” on the PI. However I still can not consistently connect to my Windows Folder. Sometimes I’ll be able to see to some of the folders but most of the time I get error messages. I think my windows folders are set up correctly because I can connect to them via my phone.