Connection Refused

Hi, After installing the 2015.06-1 on a clean sd card, i cannot connect by ssh. its keeps telling me connection refused. i can ping but no ssh and no scp. Reinstalled twice to confirm. i made no changes but enable the ssh service. removed an reinstalled didnt solve. All other option on google i tried, didnt work.

Greetings Thomas

You shouldn’t have had to do this even. It’s enabled by default on all installs. You are either trying to connect to the wrong IP or you are using the wrong user:pass combo, which in osmc would be osmc:osmc.

It is default indeed i only checked it sry for misunderstanding

Ik am connecting to the right ip like its setup in dhcp on the router always worked before on openelec same ip and user pass is also osmc osmc

What are you trying to connect from?

Putty win10. and also tried winscp disabled firewalls didnt work

If you are attempting to connect to the correct IP, the correct port (22), and using the correct credentials, then only something in your network (router/firewall etc) could be causing the connection to be refused.

I have disabled bitdefender firewall windows firewall and i even portforwarded 22 (not nessesairly needit under lan but still) i will put my pi in dmz mode in the router to confirm if its an router issue

Try to double check via OSMC network that you have the right IP…

and if not already use ethernet to test the connection…



Double check the IP address under My OSMC -> Networking.

SSH is enabled by default on a fresh install, there is no reason why it would be disabled.

Like i re-posted indeed it was enabled by default :wink: ip is correct like i said i can ping to it. And i am going trough lan

All your talk of port forwarding and DMZ makes it sound like you are trying to SSH in from a location across the internet ? Is this the case ? Or are you connecting from a machine on the same local network.

Im connected as lan but i dont know what to try else i know dmz doesnt make any sense

Found the problem, my ipcam had static ip setting on 1.7 :slight_smile: fixed it by adjusting it to dhcp that gives it 1.8 thanks, feel stupid now :stuck_out_tongue: