Connection to OSMC from outside lan

I tried to find answers on google but I not found nothing.
I connect to my osmc with ssh and ftp on local lan, works perfectly! then I use dns service ( to connect from outside. Ssh and ftp connect and I try to login but their answer is “Access denied” for SSH and similar for ftp.
I tried also to make a new user but it is the same…
There is an interdiction? where?
Many thanks!!!

Possibly port forwarded to the wrong device.

The port works fine because I enter on login, but reject my password.

Either your port forward is pointing to a different device on your network and so your password isn’t working. Or you are entering the wrong password.

1 Like

Is your no-ip host name resolving to the correct IP address ?

What external port are you forwarding to the Pi ?

I connect to the correct device, I’m sure, I have only one raspberry on my lan.
I haven’t problem of ip, forwarding etc because I enter on login.
I think that there is a rule that block the login from outside of local lan

Solved! I found that the problem is router of Swisscom. It uses the port 22 but isn’t on router configuration, I think that is for remote assistence or configuration. I changed the port for SSH on OSMC and it works, in file /etc/ssh/sshd_config
Thanks for all!!

So when you thought you were connecting to your Pi you were in fact connecting to your router?

yes, :frowning: I did not know because on configuration router there isn’t a SSH configuration, it’s hide on firmware… I think.