Connman failed after removing openvpn

#1

Hello friends.
I have tried for the second time to configure OpenVPN following some youtube tutorials and I have failed again. I ended up with the same mistake I’ve done few months ago, removing openvpn from the system.
Making this mistake, it costs me that connman doesn’t work anymore and I don’t have any internet connection on my Pi3 running OSMC.

The 2nd time I screwed up things I had to reinstall OSMC, but now I am reaching out for your help as I don’t want to reinstall everything.

Removing openvpn (2.4.0-6+deb9u3) ...
dpkg: armv7-network-osmc: dependency problems, but removing anyway as you requested:
 rbp2-device-osmc depends on armv7-network-osmc.

Removing armv7-network-osmc (1.7.6) ...
WARNING: You have tried to remove a package that is essential to OSMC's operation.
To undo these changes, run 'sudo apt-get -f install'.
dpkg: error processing package armv7-network-osmc (--remove):
 subprocess installed pre-removal script returned error exit status 1
dpkg: armv7-connman-osmc: dependency problems, but removing anyway as you requested:
 armv7-network-osmc depends on armv7-connman-osmc (>= 1.2.9-3).

Removing armv7-connman-osmc (1.3.6-2) ...

I still can access it by ssh-ing into it on the local IP but no internet at all.

Later update

I have manage to download manually openvpn and armv7-connman-osmc and upload it onto the Pi, install both packages from terminal. It looks like I have an internet connection if I configure manually the network.

The main issue that still stands is, after I reboot the Pi, I have to do all the configurations again in MyOSMC.

No internet for Kodi
#2

baked into osmc so its not removable

#3

Kinda sorted it… Pi has internet connection so I can ssh into it from the internet, deluge it’s working fine seeding my torrents but Kodi doesn’t have any internet connection. I’m not sure where’s the problem here. How can the Pi has internet but Kodi not?