Constant crashing

OK, Iv’e got into it and installed a clean Kodi, see if it freezes at 17:50

It still froze at 17:50 with the clean Kodi install
Can someone interpret the logs? is is a very repeatable bug, it occurs at exactly hour + 50 minutes of every hour regardless of how long the Vero has been powered up in that hour

Ok much shorter log here, I started it at 18:49, it froze as the flip clock changed from 18:49 to 18:50 exactly (and my flip clock is precise)

That sounds like a cron job or some home automation stuff.
Maybe move back your original Kodi folder and then make a backup via MyOSMC. After that do a reinstall.

I have made a backup, how do I reinstall? I assume you don’t mean to reinstall the backup.
I have noticed a hotfix called lanevudaqu is showing, is this a system feature?

Where do you see that?
There haven’t been any hotfixes published for a long long time.

Since it sounds like a time based execution I’m thinking Cron or At. Have manually installed either one?

If so a log of your system crontab might give clue:

cat /etc/crontab | paste-log

Ps. That command might be wrong, mobile right now and type from memory.

I have not installed them

It could also be a systemd timer. What’s the output from running:

systemctl list-timers

1 Like

There are 2 timers set, I tried to copy but right click just brings up a list of commands, not the option to copy as is normal in a dos box

Sorted the copy problem
Fri 2021-07-16 08:55:32 BST 23h left Thu 2021-07-15 08:55:32 BST 18min ago osmc-report-stats.timer osmc-report-stats.service
Fri 2021-07-16 09:05:32 BST 23h left Thu 2021-07-15 09:05:32 BST 8min ago systemd-tmpfiles-clean.timer systemd-tmpfiles-clean.service

I have done so, Sam, it was frozen again this morning when I tried to connect with it, I bought it March 2020, can I get a replacement? please

You done the reinstall? Can you provide updated debug enabled logs?
Is the crash still happening at 50 minutes after the hour?

Its not freezing at 50 mins past now but it is random, was frozen this morning and again now, will it be worth running a logging tonight?

Once again, can you confirm whether you have reinstalled OSMC?

Ok, I confirm once again, I have re installed OSMC, as I previously posted

Unfortunately, it is hard to understand what the root cause could be. If it is a HW issue of the Vero itsself, I would expect the crashes to come more arbitrary.
In theory, it would be helpful to try the Vero in a different location, e.g. with a neighbor, a friend, etc., just to see whether the problem moves with the box.

If you want, you can try to activate persistent kernel logging but not every user wants to follow these longish instructions:
If you think you can, follow the steps below:

  1. login via SSH to the OSMC device, user osmc, password osmc
  2. cd /var/log
  3. sudo mkdir journal
  4. (from now, kernel messages are written to new directories for every boot)
  5. sudo shutdown -r now
  6. now wait for the issue/event which is the problem of this topic
  7. once it happens again and you are forced to reboot the OSMC device or it rebooted automatically, you’ve to identify the right kernel message log:
    7.a) login via SSH and invoke
    sudo journalctl --list-boots --no-pager
    7.b) the lines start with an index id like 0, -1, -2, etc. and contain the date and time when log was started
  8. upload the appropriate kernel log using
    sudo journalctl -k -b <identified index> --no-pager|paste-log
    (replace <identified index> with the real index id, see above)
  9. also, upload the appropriate full log using
    sudo journalctl -b <identified index> --no-pager|paste-log
    (replace <identified index> with the real index id, see above)
  10. provide the returned URLs here
  11. don’t forget to remove the created journal directory otherwise your system’s root file system gets filled
    11.a) login via SSH
    11.b )cd /var/log
    11.c) sudo rm -R -f journal && sudo reboot (repeat this line if you get a ‘cannot remove’ error until it works and your ssh connection gets lost by the reboot)

Thx for your time. We hope to help you, soon.

PS: Keep the kodi logging while running with persistent kernel log.

When you reinstalled - did you set everything up again, or restore a backup?


I reinstalled and ran it, it froze so I reinstalled my backup. That h+50 mins seemed to be just for that day, it is now freezing at random. In the 16 months I have had it it has been superbly stable, it has gone crazy since my 2 weeks away, I think it missed me!

Well, last idea I give: If you have a USB-A male/male cable and a USB 5V PSU or PC you could try to operate the Vero WIHTOUT the original PSU but powered by the USB-cable … but just for these tests and not as a permanent workaround.
The OSMC remote dongle you can insert into the USB hub visible on the other USB port of the Vero. Both USB hub and hdd should be self-powered to reduce power consumption to a minimum.

If this works stable it would mean the original power starts dying / running out of specification.