Constant crashing

I have owned my 4k+ now for some time, it has crashed a couple of times in the past, since my return from holiday last week it has crashed probably a dozen times, was anything altered from 14th June to 30th June? I forgot to add that it has had stuttering on the audio a couple of times this week also, never had anything like that before, video was running fine but audio sounded like a ropey CD

  1. Not on the stable release, only if you are on the testing/beta release
  2. Generally nothing will install itself without you agreeing to it

If you want to get any ideas what is going wrong upload debug enabled logs

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Difficult as to how I can log it, it seems to happen overnight when the Vero is in suspend mode. When I next try to power it on there is no response to remote signals, no display output and it is unreachable on the network. The only way I can get it back to life is to pull the power and let it reboot. How can I log this problem?

Uploading the logs as indicated will include the Kodi.old.log which might give us some ideas. Best with debug logging activated

Thanks for the help, I enabled logging and was going into the menu when it froze again. I pulled the power, rebooted twice, let it run for a few minutes, stopped the logging then got this link
I have tested it, there is a log there, thanks John

From a very quick glimpse of your logs, it looks like the last thing you did was exit Kodi. Can you confirm if this is the case?


No, I dont exit kodi

Kodi was exited here:

2021-07-11 08:53:17.238 T:4067205136 NOTICE: XBApplicationEx: application stopped!

after some remote presses.

Hi Sam, would that be when I had to remove the power as it had frozen? I obviously pressed the remote keys a few times and got no response so had to power it down

What is that ADDON: cpluff, it seems to be causing problems

I have just noticed the Youtube updated 01/07/2021, I have now deleted it, it never worked anyway

No - removing power wouldn’t show Kodi exiting and logging would stop (no power to write to log).

It looks like there were some remote presses beforehand.

Are you able to ping the device when it is not responsive?

I am not able to see it as a network drive on the PC, have not tried pinging it though

It has just frozen again, destination host unreachable when pinged. I will upload this log now
It froze at 12:50, that time was still displayed on the tv screen along with the logging which was frozen

It was not doing anything when it froze, just showing the menu screen

The quickest way to get back up and running and rule out some add-on issues would be to reinstall OSMC.

Is there a way of saving the settings as I had a tough time getting everything working with it initially?
I am powering it through USB to rule out power supply issues at the moment, it has frozen about 6 times today so may find out soon

Well you can backup via the Backup Tool in MyOSMC but as the most likely point is a problem in your settings or addons that would bring back your issues. Before a OSMC reinstall you could try with a clean Kodi Config (that you can restore if it doesn’t solve the issue.

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

More info, it is freezing at exactly h:50 minutes every hour, last one was 16:50, with it being so regular it should be possible to find the cause, I have the last log here

I have tried to ssh into it, it is denying the validity of my password