Constant CVideoPlayerAudio::Process - stream stalled renders Vero4K+ unusable to watch any Youtube video

I own a Vero4K+ for years now, mainly to watch youtube video in the comfort of my couch. First time I post in here.

I made all the updates along the years and got used to the fact google regularly breaks the youtube plugin by introducing some new fancy anti oss measures, that fortunately the youtube plugin devs are able to quickly circumvent.

Since I upgraded to 19 I got some minor issues. First the update was the first one in years that actually failed and required me to update things manually from a console, but eventually things stabilized.

The problem is that for few weeks now, I can’t watch decently any youtube video anymore, which is my primary usage of the vero4K+/osmc/kodi, it freezes all the time, with the same messages coming again and again in the kodi log:

2021-10-12 23:07:20.850 T:10441    INFO <general>: CVideoPlayerAudio::Process - stream stalled pts:573.301 clock:573.303 
2021-10-12 23:07:36.199 T:2723     INFO <general>: CActiveAESink::OpenSink - initialize sink
2021-10-12 23:07:36.199 T:2723     INFO <general>: CAESinkALSA::Initialize - Requested layout: FL, FR
2021-10-12 23:07:36.199 T:2723     INFO <general>: CAESinkALSA::Initialize - set digital_codec 0
2021-10-12 23:07:36.199 T:2723     INFO <general>: CAESinkALSA::Initialize - Attempting to open device "default"
2021-10-12 23:07:36.206 T:2723     INFO <general>: CAESinkALSA::Initialize - Opened device "default"
2021-10-12 23:07:36.207 T:2723     INFO <general>: CAESinkALSA::InitializeHW - Your hardware does not support AE_FMT_FLOAT, trying other formats
2021-10-12 23:07:36.207 T:2723     INFO <general>: CAESinkALSA::InitializeHW - Using data format AE_FMT_S24NE4
2021-10-12 23:07:36.209 T:2723     INFO <general>: CAESinkALSA::Initialize - speaker layout 0

and again and again… every 30s or so.

I know this forum is about osmc and not the youtube plugin for kodi, but I feel really at the end of the road now… I think I read everything I could but couldn’t find anything to fix this, and was wondering if I could get any useful advice from this forum…

I am experiencing the exact same issues I couldnt find a fix for. According to this open bug it seems like yt has changed something: Buffering Bug · Issue #163 · anxdpanic/plugin.video.youtube · GitHub

I already tried the current alpha2, but as already in the comments, it doesnt really help. Seems lile we need2wait some time unless some1 has another idea.

Just tried the 18 alpha2 (select unofficial matrix for kodi 19) It fixed the problem for me !