Continous red cross


my Vero4K shows a a red cross, even if I change the power supply, which was an issue a while ago until I changed to a new one. Is there anything else I can check, before I should consider this unit dead and order a new one? And are deliveries to EU without any problems at customs?

Hey, if you come to the conclusion that you need to order a new device, I just want to let you know I got a spare 4K+ that I don’t need anymore. I’d sell it for 85 €, shipping from Germany.

1 Like


Have you tried powering it via a USB-A cable?
Or reinstalling OSMC from Download - OSMC?

We will launch a new Vero shortly – so you may wish to wait for that if you do need to replace it.


OK, reinstalling OSMC solved it. Thanks Sam!

Glad to hear this.

Hi Ainsley,
it seem i have same issue as Jorg had. I tried to reinstall yesterday, but with no luck.
Let me try to use usb-a cable instead of the official power cable.

When do we expect the new model? What’s in the specs, please?


All will be revealed in time.



1 Like