Control Vero 4K+ with TV remote?

I was unable to find an answer to my question here so i’ll ask, is it possible to control the Vero with my TV remote?
I have an LG C9 which has a ‘magic remote’ that can supposedly control other devices but i havent had success doing so.
HDMI-ARC is not an option as i’m using it for my receiver and connecting the Vero to my receiver is also not an option as it is not a 4K capable receiver.

Has anyone had success with this?


Yes. This is called CEC.
If this cannot be used, then you could program IR codes for the internal receiver.


Thanks for the quick reply @sam_nazarko

Should this just work out of the box or are there some things required to get this working?
I’ve taken a look in the CEC settings on the Vero box but that didn’t clear it up for me, that just looked like the Vero controlling things instead.

It should work out of the box

@sam_nazarko thanks for clarifying.

I’ve digged a bit further and it appears i will need to capture the inputs from my remote via debug logging and setting these via the keymap (from the kodi wiki).

However, i’ve opted not to enable SSH during the setup and i can’t find where to enable it and the OSMC wiki only clarifies how to log in not how to enable it after the fact.

I know this is off-topic, but can i enable SSH without reinstalling the device?

You shouldn’t need to go the ir route. You should only have to go into your TV menu and turn on “Simplink”, aka CEC, and then it should just work without changing anything else in the TV or the Vero.

@darwindesign Thanks, “Simplink” is on however the Vero is unresponsive to the LG Remote inputs (menu navigation/OK/pause/play etc).

Is there anything else i could have missed?

If you programed the remote for some kind of device and are trying to use that then that may be your issue. I’m not really familiar with how these magic remotes work but my best guess is that you may be trying to use it the way things are done outside of CEC. With the ‘old school’ remotes you had devices being controlled separately and directly from the remote. With CEC you leave the remote on the TV controls and the TV then forwards the commands to whatever compatible downstream equipment over the hdmi cable. You don’t switch what device your trying to control on the remote when your using CEC.

Also if you just turned CEC on you may need to reboot the Vero.

killing the power to both the tv (pull the power cord so its really off) and the vero is another thing that has helped for me when it didnt wanted to work.

Sometimes it helps to select another hdmi source and use the remote to do some action there and then switch back to the vero (with the remote), (can take up to a minute before it starts to react to any inputs).

1 Like

On my cheap “Digihome” TV i had to enable “virtual remote” to get it to send remote signals over CEC.

My Vizio remote controls my Vero 4k+, noticed it by accident one time by grabbing the wrong remote.

I appreciate all the inputs here, i tried everything but unfortunately im unable to get it working which is a bit disappointing(not blaming the Vero here).

I’ve also tried disconnecting every other HDMI device from my TV and tried different HDMI ports too, it just doesn’t work at all.

I’m at a complete loss on how to troubleshoot this, the only option i can think of is to see in the debug logs if the vero is actually receiving inputs, i just can’t find where to turn on SSH.

You could run cec-client via SSH with Kodi stopped.

Open the MyOSMC add-on, click on “app store” then “SSH Server” then move the selection to the right and click on “Apply”.

Open the MyOSMC add-on, click on “Services” then “SSH Server” then move the selection to the right and click on “Apply”.

It can be enabled under Services section of My OSMC. The SSH server can never be uninstalled.

I just looked into how this magic remote works and it would seem you need to go back into the device connector settings and program the input the Vero is plugged into for using Simplink in addition to having the Simplink turning on in general. By programing that device the way you did it disabled CEC on that input. It probably wouldn’t hurt to also go in Kodi to settings>system>input>peripherals>CEC Adapter and make sure it is set to “enabled”.

Thanks all for taking the time to respond.
I wasn’t able to try these steps before it randomly started working without me doing anything, it seems to have started working after an update but i cant really be sure if that was the cause.

I would have liked to know what was causing it but im afraid of breaking it if i try something now.

I highly doubt it “just fixed itself”. I would venture a guess that you ran the device connecter again after turning CEC on in the general settings and were offered a new option for that input.