Corrupt Boot Partition or Card? [solved]

After a Summer power cut, I think my SDcard may be corrupt.
Im running OSMC December 2018 update on Pi Model2 with Sandisk 16G card

Every time I reboot my Pi, I get an error tring to read from


This device does not exist and a reboot results in either a segfault or will boot nornally.
I have SSH access again and have uploaded grab-logs -A to:

I can remove SD card and run fsck.ext4 against the ext4 partition on my linux laptio but not sure how to check the fat32 partition.

Originally I bought MPG2 and VC1 license keys the commands:

osmc@osmc:/boot$ vcgencmd codec_enabled WVC1
osmc@osmc:/boot$ vcgencmd codec_enabled MPG2

State that the licenses are enabled. I remember appending keys to /boot/config.txt
but the contents of this file do not contain license keys. Could this be down to corruption?

osmc@osmc:/boot$ cat config.txt


Is there any other place license keys are stored?
If not I can play mpg files I will just order new license keys.

I can still access other logs t moment in case paste bin is insufficient.
Thanks in advance

After a successful validation licence keys are now stored in firmware. So no need to add them again

Thanks fzinken for the info about the license codes that makes sense to store in firmware.

AS to corruption, I deleted ~/.kodi and rebooted with no addons.
Everything seems ok again now. At some later date Iwill check my SD card in another computer and possibly reload.
Will mark as solved to save reading message again.