Corrupt Profile?

I have something fishy going on with one of my user profiles on the Vero 4K.

I have two profiles setup, one for the Adults and the other for the kids.

Way back when Kodi V18 was released after updating I had a couple of issues, both profiles was using the Mimic Skin, which is no longer supported in V18. After rebooting following the update, things went a bit wrong but I eventually managed to (somehow!) get back into the skins menu of the main Adult account and set a new skin (Aeon MQ5) and everything was fine on this side.

However in the Kids profile, this has remained using Mimic which appears to be working perfectly fine as it is, however things I’ve now noticed;

  1. Browsing the ‘Get More Skins’ list does not show the full list of V18 skins available, its a very limited pool of skins and Aeon MQ5 is not in the list.
  2. Changing the skin to OSMC default and running a MyOSMC firmware update check does not work. Error log here:
  3. Changing to any other skin in my list other than Mimic or MyOSMC errors out.

As strange as it sounds, it feels like the Kids profile hasnt been successfully updated to V18, so I really dont know whats going on.
I’ve updated the log above but just realised I didnt reboot after enabling logging, not sure how critical this is, I can do it again if required.

As an side and it might not be an issue, the firmware was updated a week or so back (through the main user profile), but I noticed it’s still date stamped for July (2019.07-1), although all updates have been successful.

Thanks in advance.

Profiles are somewhat broken in Kodi v18
What skins are available to install?
Can you clarify what you mean by ‘errors out’?



I tried to update OSMC around 3 or 4 times earlier, from the Mimic skin all I could get to was this screen;


From the OSMC Skin it just presented an error which was along the lines “update failed”. Apologies I didnt get the exact message but believe it should have been captured in the log above.

Ive just gone to try and replicate this again to confirm the message and the updater actually worked and more surprisingly updated the OS from the Kids profile.

Either way, the updated is working now but not all skins are listed in the more skins section (Aeon MQ5 is listed in the adults profile but not the kids)… its not a major end of the world but something fishy is definitely going on I think?

Try flip to the OSMC skin. I wonder if you’re still running a Krypton version of your skin which could explain things looking weird


====================== APT sources.list =================== ZZz2wrJ1

deb stretch-devel main

You may want to switch back to stable releases.

As for the kids profile I would maybe try renaming or just deleting the guisettings.xml file from the kids profile and see if that gets you anywhere.