"Could not connect to repository."

I have a Raspberry Pi 4b with OSMC 2023.07-1. OSMC was sent to me installed on the OSMC SDCard. I updated to the latest OSMC over the internet through my router. I went to the Add-on browser and selected “Install from repository”. On the Kodi Add-on repository screen I have “Could not connect to repository.”. I reinstalled the latest OSMC with the OSMC install app and updated again. I still get the same message “Could not connect to repository.”. I am able to SSH from my Ubunu PC. I activated the logs and rebooted twice. The log link is: https://paste.osmc.tv/ulubohinik

I tried “rm -rf ~/.kodi” and then “shutdown -r now” after I turned the logs off, but received the same no connection message.

Thanks for any advice.

I’ll check this shortly. There was a report of an issue with the repository earlier but I thought I had it resolved.

I will check things on my side in a bit.

Thanks. It seems to be working fine here now. This is outstanding. Thanks.

To be honest - I didn’t do anything. Everything was up here, but I waited a few hours to monitor things.

May have been an intermittent connectivity issue.