Could not mount filesystem

I’m using an Ubuntu flavor version 16.04. I just downloaded and installed the installer and am trying to write to a MicroSD view a SD card reader. I had already formatted the card so there is nothing on it. When I run through the wizard it gets as far as writing to the card but fails stating that it can’t mount the filesystem. Looking at the log here are the last entries:

Fri Feb 3 21:19:58 2017 Writing preseeder
Fri Feb 3 21:19:58 2017 Running partprobe to inform operating system about partition table changes
Fri Feb 3 21:19:59 2017 Mounting the first filesystem on /dev/sdd
Fri Feb 3 21:19:59 2017 Trying to umount before we are remounting and writing the preseed.
Fri Feb 3 21:19:59 2017 Unmounting /dev/sdd1
Fri Feb 3 21:19:59 2017 Running partprobe to inform operating system about partition table changes
Fri Feb 3 21:19:59 2017 Unmounting /dev/sdd
Fri Feb 3 21:19:59 2017 Running partprobe to inform operating system about partition table changes
Fri Feb 3 21:20:00 2017 Mounting /dev/sdd1 to /tmp/osmc_mnt
Fri Feb 3 21:20:00 2017 Could not mount filesystem!

Any help would be greatly appreciated. I even attempted to run the installer via command line with sudo but got the same result.

Use a different SD card. It’s probably faulty or not genuine. If the issue persists, change the card reader.
You should also upload full logs in future.

Where would I upload the log? Just copy/paste to this thread?
Also, I chose SD card during the wizard since there is an SD card in the USB card reader. Should I have chosen USB instead?
I will try that to see.

Please use http://paste.osmc.io for your logs.

You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Here’s the log:

http://paste.osmc.io/yapuxeluse.vhdl

I’ll try a different SD card today.

Same result with a different SD card.

http://paste.osmc.io/tukimilavo.vhdl

Have you tried a different card reader?
Also what happens if you try to mount /dev/sdd1 manually afterwards?

I’m pretty sure it’s not the card reader since I’ve been using it to build Raspberry images to SD cards for a while with no issues.
I will test the manual mount later this evening when I get home from work.
I’m thinking my next step is to attempt to not use the OSMC installer and just dd the image to the SD card to see what happens.
Also, I just looked over the log a little closer and it seems to me that the image is written to the SD card. When I get home I may try to boot up my RPi with the SD card (may try both) to see if it still boots and is functional despite the error message.

So the SD card seems to be fine despite the error message. I attempted to boot up in the RPi anyway and, so far, it seems fine. Went through the wizard and now I have a working OSMC device.
Now, I just need to figure out how to configure the network for static IP. :wink:

You mean how to configure your router to give the OSMC deivce a fixed IP via DHCP or how to configure OSMC to use static IP instead of DHCP.
For the later one just go to MyOSMC -> Network

Yeah, I found it. Thanks.

So, is the experience I went through with the installer a bug? Is this something that should be fixed in case someone else comes across the same issue and gets confused?

Not seen this before firsthand.

Your log shows dd succeeds, but mounting the card fails, so preseeding isn’t possible. I have heard of this happen in cases of high uptime, a bad card / reader, or an application that ‘grabs’ the device which prevents the from writing the preseeder out (and set up network settings on first boot).

This isn’t common at all. Without further logging or knowing more about your system it’s hard to say what happened, but if you reinstall OSMC at some point and experience this again, ps -aux and dmesg could possibly yield some clues.

Looks like the same thing happened over here: Preseeding fails with two different brand new OSMC SD cards, an SD card reader which seemed to be reliable for many months, and Ubuntu 16.04 LTS (kernel version 4.8.0-53).

OSMC installer log: http://paste.osmc.io/feqepukula.vhdl

Unfortunately, it’s been a couple of days ago (just discovered the log file). If it would help I’d try again with more logging in the next couple of days.

dd manually for now.

I suspect something like Nautilus is grabbing the device. I have a Ubuntu 16.04 setup here so will investigate.

I’ve been having this problem too a ton. I can’t yet rule out the SD card being at fault, but for sure when I manually do the sudo mount /dev/sdf1 /tmp/osmc_mnt it works.

What would be really good is if the installer didn’t just bail it was able to retry the mount. That at least gives the user a chance to try to sort things out without having to go all the way back to the beginning.

So far I’ve tried 3 card readers, 6 SD cards and 2 computers. All give the same problem. I’m not ruling out faults in any of this yet, but for sure a retry on the mount would help a lot.

I’ve tried to manually do a dd of the image and start with that, but it seems to be stuck on formatting device so there is clearly something else wrong too.

I don’t even really any of this as I used NFS booting before and the old SD card died, but there’s no way to just get a new boot SD card for that without going through the whole installer thing.